aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-21 06:36:34 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-03-29 23:54:43 +0300
commitd5454103c09d4ab7d3c8c268c9039d1ef818ec90 (patch)
tree79b0b7dc206501e66df4bf4dc3f02dd7f53467e1 /testing
parent62eb34f2debd8fea32ecff0a6b1ac60422fc3eb4 (diff)
downloadaports-d5454103c09d4ab7d3c8c268c9039d1ef818ec90.tar.bz2
aports-d5454103c09d4ab7d3c8c268c9039d1ef818ec90.tar.xz
testing/php7-ast: modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-ast/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/testing/php7-ast/APKBUILD b/testing/php7-ast/APKBUILD
index b20adc4b60..a0a2a3ea10 100644
--- a/testing/php7-ast/APKBUILD
+++ b/testing/php7-ast/APKBUILD
@@ -5,31 +5,33 @@ _pkgext=ast
_pkgreal=php-ast
pkgver=0.1.6
_pkgver=${pkgver/_rc/RC}
-pkgrel=0
+pkgrel=1
pkgdesc="PHP7 extension exposing PHP 7 abstract syntax tree"
url="https://github.com/nikic/php-ast"
arch="all"
license="BSD"
depends="php7"
makedepends="php7-dev autoconf"
-install=""
-subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/nikic/php-ast/archive/v$_pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgreal-$_pkgver
+
build() {
cd "$builddir"
- phpize7 || return 1
+ phpize7
./configure --prefix=/usr \
- --with-php-config=/usr/bin/php-config7 \
- || return 1
- make || return 1
+ --with-php-config=/usr/bin/php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {
cd "$builddir"
- make INSTALL_ROOT="$pkgdir/" install || return 1
- install -d "$pkgdir"/etc/php7/conf.d || return 1
+ make INSTALL_ROOT="$pkgdir/" install
+ install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgext.so" > "$pkgdir"/etc/php7/conf.d/$_pkgext.ini
}