aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-12-31 11:32:46 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-12-31 11:38:48 +0200
commitdac091c2a6fb9b7cadbe2f130e3afab37201cb1c (patch)
tree2c33769701b8c0684c63a1263eefee7ce21571d7 /testing
parent2ecb961213417cec5c31f24a83302dca4dfc6514 (diff)
downloadaports-dac091c2a6fb9b7cadbe2f130e3afab37201cb1c.tar.bz2
aports-dac091c2a6fb9b7cadbe2f130e3afab37201cb1c.tar.xz
testing/lua-resty-openidc: new aport
OpenID Connect library for the nginx lua module https://github.com/zmartzone/lua-resty-openidc
Diffstat (limited to 'testing')
-rw-r--r--testing/lua-resty-openidc/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/lua-resty-openidc/APKBUILD b/testing/lua-resty-openidc/APKBUILD
new file mode 100644
index 0000000000..f456401953
--- /dev/null
+++ b/testing/lua-resty-openidc/APKBUILD
@@ -0,0 +1,21 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=lua-resty-openidc
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="OpenID Connect library for the nginx lua module"
+url="https://github.com/zmartzone/$pkgname"
+arch="noarch"
+license="BSD2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zmartzone/$pkgname/archive/v$pkgver.tar.gz"
+depends="lua-cjson lua-resty-string lua-resty-http lua-resty-session lua-resty-jwt"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/usr/share/lua/common"
+ cp -r ./lib/resty "$pkgdir/usr/share/lua/common"
+}
+
+sha512sums="c26e530c5f1fcf8d4939820b1541e70444efb63dc60e3834231812d86c8f7c06c06ad1b12b79b94d27338b93f32e5a1acd78158d9aed4b9a4f8f133fc6a17625 lua-resty-openidc-1.7.0.tar.gz"