aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-02 03:30:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-08 01:04:40 -0300
commitde5fa6531b3b6b4775bc0edb262defc4ea4596a0 (patch)
tree97476e6bc5b997d08d8b9d462523acf84cbd40fd /testing
parent58cdadabf65f49f132ebdcf79eb49f7f20a383d2 (diff)
downloadaports-de5fa6531b3b6b4775bc0edb262defc4ea4596a0.tar.bz2
aports-de5fa6531b3b6b4775bc0edb262defc4ea4596a0.tar.xz
testing/py3-pbkdf2: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pbkdf2/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pbkdf2/APKBUILD b/testing/py3-pbkdf2/APKBUILD
new file mode 100644
index 0000000000..49f4180828
--- /dev/null
+++ b/testing/py3-pbkdf2/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pbkdf2
+_pkgname=python-pbkdf2
+pkgver=1.3
+pkgrel=0
+pkgdesc="Password-based key derivation function"
+url="http://www.dlitz.net/software/python-pbkdf2"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dlitz/${_pkgname}/archive/v${pkgver}.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="642372615a2ffc9cf352805789f836c42763c49cbf113d64524a55c6ff8a09f0fda36c92713387f27c2f6a2950ce89ae04dc9f92495cba904400685b148f947e py3-pbkdf2-1.3.tar.gz"