aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-02-20 20:30:01 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-20 17:43:40 -0300
commitdf5f74b0320f09f8b939be2f98722b2ab4038c30 (patch)
tree0a34ac4a98ecfc2833d36aa4436f1703c494212d /testing
parent94e688a3faa34a410ab53d60170046223cb2e22e (diff)
downloadaports-df5f74b0320f09f8b939be2f98722b2ab4038c30.tar.bz2
aports-df5f74b0320f09f8b939be2f98722b2ab4038c30.tar.xz
testing/py3-slugify: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-slugify/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-slugify/APKBUILD b/testing/py3-slugify/APKBUILD
new file mode 100644
index 0000000000..0c2644793b
--- /dev/null
+++ b/testing/py3-slugify/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=py3-slugify
+pkgver=4.0.0
+pkgrel=0
+pkgdesc="A Python slugify application that handles unicode"
+url="https://github.com/un33k/python-slugify"
+arch="noarch"
+license="MIT"
+depends="python3 py3-text-unidecode"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/un33k/python-slugify/archive/$pkgver.tar.gz"
+builddir="$srcdir/python-slugify-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 test.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="a4b0da48ee887a24a022076c9b21fa5795ab104b1d382bae96fc7ba5ce6c09c0cc42e1f4c3b6874b44097d2246ea5b18302dc42386d8844fa41f495744e5ed90 py3-slugify-4.0.0.tar.gz"