aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2016-06-07 17:39:15 +0300
committerJakub Jirutka <jakub@jirutka.cz>2016-06-08 22:48:16 +0200
commite07019964b87b8d37c77bd529a3e3c1ad180ffd6 (patch)
treed77d860c68625f1176967498450d84e4621aef55 /testing
parent87bde8222bd830d425cc2a455bb916fb392bd138 (diff)
downloadaports-e07019964b87b8d37c77bd529a3e3c1ad180ffd6.tar.bz2
aports-e07019964b87b8d37c77bd529a3e3c1ad180ffd6.tar.xz
testing/php7-apcu: new abuild
http://pecl.php.net/package/apcu PHP extension APC User Cache
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-apcu/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-apcu/APKBUILD b/testing/php7-apcu/APKBUILD
new file mode 100644
index 0000000000..4cb9143722
--- /dev/null
+++ b/testing/php7-apcu/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=php7-apcu
+_pkgreal=apcu
+# release 5 is php7+
+pkgver=5.1.5
+_pkgver=${pkgver/_rc/RC}
+pkgrel=0
+pkgdesc="PHP extension APC User Cache"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=""
+pecldepends="php7-dev autoconf"
+makedepends="$pecldepends pcre-dev"
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+md5sums="fcb4a8214419121bfae1b1288fe6697f apcu-5.1.5.tgz"
+sha256sums="5f4153fe21745a44f1d92431b05a85c0912bb3235110615db84a4a6e84fb6791 apcu-5.1.5.tgz"
+sha512sums="ffa3e666f354c8fd2ab163db9c8352066d27a1cd6aebe4d8f374052f14a90dbe752efc27c6e927cbf75fc48b6f673e639b07ceeffc2a68402a778cc6a8b18fbc apcu-5.1.5.tgz"