aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2018-07-17 16:16:11 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-07-18 07:06:05 +0000
commite110f59bb83fd6b53b51c00289f28d00ce01bfdc (patch)
tree2e25a804ddccd6722b5a0f488d950aea2a7bad73 /testing
parent1ad36959e0d5c54935b183c11cc09d5adacf6f65 (diff)
downloadaports-e110f59bb83fd6b53b51c00289f28d00ce01bfdc.tar.bz2
aports-e110f59bb83fd6b53b51c00289f28d00ce01bfdc.tar.xz
testing/dfu-utils: New aport
Host side implementation of the DFU 1.0 and DFU 1.1 specifications http://dfu-util.sourceforge.net/
Diffstat (limited to 'testing')
-rw-r--r--testing/dfu-util/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/dfu-util/APKBUILD b/testing/dfu-util/APKBUILD
new file mode 100644
index 0000000000..bc7375c34c
--- /dev/null
+++ b/testing/dfu-util/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=dfu-util
+pkgver=0.9
+pkgrel=0
+pkgdesc="Host side implementation of the DFU 1.0 and DFU 1.1 specifications"
+url="http://dfu-util.sourceforge.net/"
+arch="all"
+license="GPL-2.0-only"
+depends=
+makedepends="libusb-dev"
+subpackages="$pkgname-doc"
+source="http://$pkgname.sourceforge.net/releases/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build () {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="caa7148b7a9004e2b1f7bc4f1a26b48abfe311743bc0eeed1ab57459910371affc39b6fe7e74b7cac6ca9de41a9901b7a970253ca92d7d66d5008f8a11d2c952 dfu-util-0.9.tar.gz"