aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-30 23:33:33 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-03-30 23:33:53 +0200
commite200f4cf43687417d880f76ba52518e27c7e7f96 (patch)
tree1822fc9530b3b4cb0b1f6503308d8d6e4dbfcd89 /testing
parent62a466fa8c2aa2267fa5d903f5f80e39a3e25d70 (diff)
downloadaports-e200f4cf43687417d880f76ba52518e27c7e7f96.tar.bz2
aports-e200f4cf43687417d880f76ba52518e27c7e7f96.tar.xz
testing/alpine-make-vm-image: new aport
https://github.com/alpinelinux/alpine-make-vm-image Make customized Alpine Linux disk image for virtual machines
Diffstat (limited to 'testing')
-rw-r--r--testing/alpine-make-vm-image/APKBUILD24
-rw-r--r--testing/alpine-make-vm-image/no-hardened.patch22
-rw-r--r--testing/alpine-make-vm-image/only-qemu-img-is-needed.patch14
3 files changed, 60 insertions, 0 deletions
diff --git a/testing/alpine-make-vm-image/APKBUILD b/testing/alpine-make-vm-image/APKBUILD
new file mode 100644
index 0000000000..5198da9197
--- /dev/null
+++ b/testing/alpine-make-vm-image/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=alpine-make-vm-image
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="Make customized Alpine Linux disk image for virtual machines"
+url="https://github.com/alpinelinux/alpine-make-vm-image"
+arch="noarch"
+license="MIT"
+depends="qemu-img"
+source="$pkgname-$pkgver.tar.gz::https://github.com/alpinelinux/$pkgname/archive/v$pkgver.tar.gz
+ only-qemu-img-is-needed.patch
+ no-hardened.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # no suitable tests provided
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}
+
+sha512sums="1169334c4b398da95ff9c115072c09fe43dda06b4cb60a032b87b74023f73c635f52cfddf7f824faff6bef016fc7a81201f66bf22d12cb02438d9d4bc059297c alpine-make-vm-image-0.2.2.tar.gz
+54f1e16ae074dee34443e4b8f82e3eb3c07b97de515508a6b9318ed0c4db572f18d2a073b1d12bd1843a9aff00351a337b93eaed78a1046880f5da064e2230b2 only-qemu-img-is-needed.patch
+6de07784bf7e64799fc1cb8487efc784ac1e8f6a036f8c94d8e126fa9554d6848477f21590f88c251d0ee5b1ca5d94f350cd3e47092708828b3f94ea8a0c3a5f no-hardened.patch"
diff --git a/testing/alpine-make-vm-image/no-hardened.patch b/testing/alpine-make-vm-image/no-hardened.patch
new file mode 100644
index 0000000000..cd95cb0156
--- /dev/null
+++ b/testing/alpine-make-vm-image/no-hardened.patch
@@ -0,0 +1,22 @@
+--- a/alpine-make-vm-image
++++ b/alpine-make-vm-image
+@@ -32,8 +32,8 @@
+ # $ROOTFS is always included, don't specify them here.
+ # Default is "scsi virtio".
+ #
+-# -k --kernel-flavor KERNEL_FLAVOR The kernel flavour to install; vanilla, hardened,
+-# or virthardened. Default is virthardened.
++# -k --kernel-flavor KERNEL_FLAVOR The kernel flavour to install; vanilla or virt.
++# Default is virt.
+ #
+ # --keys-dir KEYS_DIR Path of directory with Alpine keys to copy into the image.
+ # Default is /etc/apk/keys.
+@@ -295,7 +295,7 @@
+ : ${IMAGE_FORMAT:=}
+ : ${IMAGE_SIZE:="2G"}
+ : ${INITFS_FEATURES:="scsi virtio"}
+-: ${KERNEL_FLAVOR:="virthardened"}
++: ${KERNEL_FLAVOR:="virt"}
+ : ${KEYS_DIR:="/etc/apk/keys"}
+ : ${PACKAGES:=}
+ : ${REPOS_FILE:="/etc/apk/repositories"}
diff --git a/testing/alpine-make-vm-image/only-qemu-img-is-needed.patch b/testing/alpine-make-vm-image/only-qemu-img-is-needed.patch
new file mode 100644
index 0000000000..9a34173744
--- /dev/null
+++ b/testing/alpine-make-vm-image/only-qemu-img-is-needed.patch
@@ -0,0 +1,14 @@
+qemu-nbd is already provided by subpackage qemu-img, so we don't need to
+install qemu package.
+
+--- a/alpine-make-vm-image
++++ b/alpine-make-vm-image
+@@ -320,7 +320,7 @@
+ if [ "$INSTALL_HOST_PKGS" = yes ]; then
+ einfo 'Installing needed packages on host system'
+
+- _apk add -t $VIRTUAL_PKG qemu qemu-img
++ _apk add -t $VIRTUAL_PKG qemu-img
+ install_fs_tools "$ROOTFS"
+ fi
+