aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-21 12:32:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-21 13:37:07 -0300
commite208f718ec7cccf20a7e9850deed1bfed8e51447 (patch)
tree94deead5bdb0c4b34c1da65378ca5b0c737d4b15 /testing
parent5873c3f50e842155291afa531d0dd94774688fa6 (diff)
downloadaports-e208f718ec7cccf20a7e9850deed1bfed8e51447.tar.bz2
aports-e208f718ec7cccf20a7e9850deed1bfed8e51447.tar.xz
testing/autofs: upgrade to 5.1.6
Diffstat (limited to 'testing')
-rw-r--r--testing/autofs/10-glibc.patch13
-rw-r--r--testing/autofs/APKBUILD8
-rw-r--r--testing/autofs/pid_t.patch14
3 files changed, 28 insertions, 7 deletions
diff --git a/testing/autofs/10-glibc.patch b/testing/autofs/10-glibc.patch
index 6dc7a47729..a02112eefd 100644
--- a/testing/autofs/10-glibc.patch
+++ b/testing/autofs/10-glibc.patch
@@ -100,16 +100,21 @@ diff -Naur autofs-5.1.4-clean/samples/auto.master autofs-5.1.4-patched/samples/a
#
# NOTE: mounts done from a hosts map will be mounted with the
# "nosuid" and "nodev" options unless the "suid" and "dev"
-@@ -12,10 +12,10 @@
+@@ -12,14 +12,14 @@
#
/net -hosts
#
-# Include /etc/auto.master.d/*.autofs
+# Include /etc/autofs/auto.master.d/*.autofs
- # The included files must conform to the format of this file.
+ # To add an extra map using this mechanism you will need to add
+ # two configuration items - one /etc/auto.master.d/extra.autofs file
+ # (using the same line format as the auto.master file)
+ # and a separate mount map (e.g. /etc/auto.extra or an auto.extra NIS map)
+ # that is referred to by the extra.autofs file.
#
-+dir:/etc/auto.master.d
++dir:/etc/autofs/auto.master.d
#
- # Include central master map if it can be found using
- # nsswitch sources.
+ # If you have fedfs set up and the related binaries, either
+ # built as part of autofs or installed from another package,
+
diff --git a/testing/autofs/APKBUILD b/testing/autofs/APKBUILD
index f6da87937e..0d507f6da6 100644
--- a/testing/autofs/APKBUILD
+++ b/testing/autofs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Alex Laskin <alex@lask.in>
# Maintainer: Alex Laskin <alex@lask.in>
pkgname=autofs
-pkgver=5.1.5
+pkgver=5.1.6
pkgrel=0
pkgdesc="A kernel-based automounter for Linux"
url="https://www.kernel.org/pub/linux/daemons/autofs/"
@@ -14,6 +14,7 @@ source="
https://www.kernel.org/pub/linux/daemons/$pkgname/v5/$pkgname-$pkgver.tar.xz
autofs.initd
autofs.confd
+ pid_t.patch
10-glibc.patch
"
@@ -49,7 +50,8 @@ package() {
rm -f "$pkgdir"/autofs
}
-sha512sums="c8138929a9e2cfa7e0096c1d490b9d7275d1d43a50f5f87ad457bdd9a49c7dd13a4aa5d86ab1e028d66dae630e1a1342661844e5775625fe585867f0f4778898 autofs-5.1.5.tar.xz
+sha512sums="dc8b2bd86c140905dd1bc461bfc469f92363d9c2687fe422e1e751cc7ad64c0733b011c80bf4840e510e5909176cd1a066968b9a5ba835b62c4cf27537863cf2 autofs-5.1.6.tar.xz
e7ffe40cf5f302f7de7cc59752699adad4be89fa78fa1a79c32ce4059ec2f563c0f107ca2cec850cabfb1cdebca5ff1f369167479423ab6cfe509225a799a00e autofs.initd
74884b94d8c5dc72579c9c0c9f13c8918ee0babe6fc1e6352bb79cfaf6f5ce3daa87a9b2ea2f34a4600c93a971b329aa0892785fe2efd42829fb7953a6130dd7 autofs.confd
-c4edd75443543aa06b7741c2ee4907718d21e791ea70abc7b2b7b8413a7a82a663a3b7ef7bad1661a5d31aab86cc934cba2b4bd0803e502f7db4e73d374adf64 10-glibc.patch"
+78dfd13e06a7adec4336b18a03a1c0bd9d651ce01bf5e716a75d5574e033db9c3fff3baf660c4a6ad757403db5242a7abecf68cdb4cc9bb4d005992b6fe44ca6 pid_t.patch
+0de8adc821fa59a9c5392ea5e4a3b540a39f38b8bb2ddde8d20ca4946e3d1467c80bb375d918a11e2331281e220da56e66c2aa1e974b9e6e40c7d3a3b4cdac5e 10-glibc.patch"
diff --git a/testing/autofs/pid_t.patch b/testing/autofs/pid_t.patch
new file mode 100644
index 0000000000..1766c34e98
--- /dev/null
+++ b/testing/autofs/pid_t.patch
@@ -0,0 +1,14 @@
+diff --git a/include/log.h b/include/log.h
+index 69eed96..14051cc 100644
+--- a/include/log.h
++++ b/include/log.h
+@@ -46,6 +46,8 @@ extern void log_crit(unsigned, const char* msg, ...);
+ extern void log_debug(unsigned int, const char* msg, ...);
+ extern void logmsg(const char* msg, ...);
+
++#include <unistd.h> /* Required for pid_t */
++
+ extern pid_t log_pidinfo(struct autofs_point *ap, pid_t pid, char *label);
+
+ #define debug(opt, msg, args...) \
+