aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-21 17:41:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-22 16:46:45 -0300
commite358716ef458cd009c01cb991c03b3349c768838 (patch)
treedd78776f50ec9556c6d816765d448d821a19db0c /testing
parentf8bc340e7ed551260856aed9386831e452a10e97 (diff)
downloadaports-e358716ef458cd009c01cb991c03b3349c768838.tar.bz2
aports-e358716ef458cd009c01cb991c03b3349c768838.tar.xz
testing/glog: Create glog pkg-config file
Diffstat (limited to 'testing')
-rw-r--r--testing/glog/APKBUILD9
-rw-r--r--testing/glog/pc-file.patch39
2 files changed, 45 insertions, 3 deletions
diff --git a/testing/glog/APKBUILD b/testing/glog/APKBUILD
index 29b5d749ea..6a2aa72c67 100644
--- a/testing/glog/APKBUILD
+++ b/testing/glog/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: David Huffman <storedbox@outlook.com>
pkgname=glog
pkgver=0.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="C++ implementation of the Google logging module"
options="!check" # Tests fail to compile on aarch64 armhf and armv7
url="https://github.com/google/glog"
@@ -10,7 +10,9 @@ arch="all"
license="BSD-3-Clause"
makedepends="cmake gflags-dev"
subpackages="$pkgname-dev"
-source="https://github.com/google/glog/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/google/glog/archive/v$pkgver/$pkgname-$pkgver.tar.gz
+ pc-file.patch
+ "
build() {
mkdir build
@@ -32,4 +34,5 @@ build() {
package() {
make -C build DESTDIR="$pkgdir" install
}
-sha512sums="b585f1819ade2075f6b61dc5aaca5c3f9d25601dba2bd08b6c49b96ac5f79db23c6b7f2042df003f7130497dd7241fcaa8b107d1f97385cb66ce52d3c554b176 glog-0.4.0.tar.gz"
+sha512sums="b585f1819ade2075f6b61dc5aaca5c3f9d25601dba2bd08b6c49b96ac5f79db23c6b7f2042df003f7130497dd7241fcaa8b107d1f97385cb66ce52d3c554b176 glog-0.4.0.tar.gz
+316de55003e4724427e7516bde98a70e7a0b75dbff91248e75fcc9c21d7b2a9d4c35b41fedd49ce4ba34f6480a31ba421948c750db17cd8ada299a2718673bd8 pc-file.patch"
diff --git a/testing/glog/pc-file.patch b/testing/glog/pc-file.patch
new file mode 100644
index 0000000000..bbb1e9ef8f
--- /dev/null
+++ b/testing/glog/pc-file.patch
@@ -0,0 +1,39 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 808330e..0b5aaff 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -664,6 +664,17 @@ if (gflags_FOUND)
+ endif (CMAKE_VERSION VERSION_LESS 3.9)
+ endif (gflags_FOUND)
+
++if (OS_WINDOWS)
++ set (PKGCONFIG_INSTALL_DIR)
++else ()
++ set (PKGCONFIG_INSTALL_DIR ${_glog_CMake_LIBDIR}/pkgconfig)
++endif ()
++
++if (PKGCONFIG_INSTALL_DIR)
++ configure_file ("cmake/glog.pc.in" "${PROJECT_BINARY_DIR}/${CPACK_PACKAGE_NAME}.pc" @ONLY)
++ install (FILES "${PROJECT_BINARY_DIR}/${CPACK_PACKAGE_NAME}.pc" DESTINATION "${PKGCONFIG_INSTALL_DIR}")
++endif ()
++
+ configure_package_config_file (glog-config.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/glog-config.cmake
+ INSTALL_DESTINATION ${_glog_CMake_INSTALLDIR}
+diff --git a/cmake/glog.pc.in b/cmake/glog.pc.in
+new file mode 100644
+index 0000000..98b54bb
+--- /dev/null
++++ b/cmake/glog.pc.in
+@@ -0,0 +1,10 @@
++prefix=@CMAKE_INSTALL_PREFIX@
++exec_prefix=${prefix}
++libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
++includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
++
++Name: libglog
++Description: Google Log (glog) C++ logging framework
++Version: 0.4.0
++Requires: gflags
++Libs: -L${libdir} -lglog
++Cflags: -I${includedir}