aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-25 17:09:51 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-25 17:10:22 +0100
commite3fcf97b39c7f0e32116a66151622af8d6dc1897 (patch)
tree1d168f80aed10ee2228a5defe5b20916cd6a2d3c /testing
parent55e9b3c7aecd79fb185744d716c4f885e4229447 (diff)
downloadaports-e3fcf97b39c7f0e32116a66151622af8d6dc1897.tar.bz2
aports-e3fcf97b39c7f0e32116a66151622af8d6dc1897.tar.xz
testing/ruby-rdiscount: fix executable
Diffstat (limited to 'testing')
-rw-r--r--testing/ruby-rdiscount/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/ruby-rdiscount/APKBUILD b/testing/ruby-rdiscount/APKBUILD
index 7a4aeb8180..2bc652f113 100644
--- a/testing/ruby-rdiscount/APKBUILD
+++ b/testing/ruby-rdiscount/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ruby-rdiscount
_gemname=rdiscount
pkgver=2.2.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Fast Implementation of Gruber's Markdown in C"
url="http://dafoster.net/projects/rdiscount/"
arch="all"
@@ -38,17 +38,18 @@ package() {
mkdir -p "$gemdir"
cp -r extensions gems specifications "$gemdir"/
+ install -D -m 755 bin/$_gemname "$pkgdir"/usr/bin/$_gemname
+
# Remove unnecessary files and rubbish...
find "$gemdir"/extensions/ -name mkmf.log -delete
cd "$gemdir"/gems/$_gemname-$pkgver
- _mv bin/$_gemname "$pkgdir"/usr/bin/
_mv man/$_gemname.1 "$pkgdir"/usr/share/man/man1/
_mv COPYING "$pkgdir"/usr/share/licenses/$pkgname/
# Remove unnecessary files and rubbish...
- rm -r bin/ ext/ lib/*.so man/ test/ Rakefile BUILDING README* || true
+ rm -r ext/ lib/*.so man/ test/ Rakefile BUILDING README* || true
}
_mv() {