aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorYura Kushnir <kushnir.yura@gmail.com>2016-10-06 13:14:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-19 16:44:38 +0000
commite445d8802701192853e65e1f5859187553a3229b (patch)
tree5e47397365705c1022130f4dc32be5eb029a51c2 /testing
parente796802671069b942735955d88011712adf2b432 (diff)
downloadaports-e445d8802701192853e65e1f5859187553a3229b.tar.bz2
aports-e445d8802701192853e65e1f5859187553a3229b.tar.xz
testing/py-urllib3: new aport
https://pypi.python.org/pypi/urllib3/ HTTP library with thread-safe connection pooling, file post, and more.
Diffstat (limited to 'testing')
-rw-r--r--testing/py-urllib3/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py-urllib3/APKBUILD b/testing/py-urllib3/APKBUILD
new file mode 100644
index 0000000000..4043f37be5
--- /dev/null
+++ b/testing/py-urllib3/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Yura Kushnir <kushnir.yura@gmail.com>
+# Maintainer: Yura Kushnir <kushnir.yura@gmail.com>
+pkgname=py-urllib3
+_pkgname=${pkgname/py-/}
+pkgver=1.18
+pkgrel=0
+pkgdesc="HTTP library with thread-safe connection pooling, file post, and more."
+url="https://github.com/shazow/urllib3"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev py-setuptools"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.zip::https://github.com/shazow/urllib3/archive/$pkgver.zip"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+md5sums="a5c3fd74a8d72803b0a9b19bdcb4d99f py-urllib3-1.18.zip"
+sha256sums="24b0213a304ebd4da902dfdcc5a9cc6abff788f6f10e85aea5f77b463bb72e15 py-urllib3-1.18.zip"
+sha512sums="535639543c5258be236f2098c74d0e089687a82f9c39c77d967da5e57f5cdc42506375bf4ee5ee209b57f9b0a4e56144a38e3addff6754ff380fe3fc20b5aaab py-urllib3-1.18.zip"