aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-17 15:00:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-18 05:57:08 +0000
commite68b6f0a78703059b51798c790b5266260264df9 (patch)
treedac27e969426e1f3ea1666c386a0bd267d76ded2 /testing
parented6a38fd363d99d24a06eba0c3d853ce982c8cc4 (diff)
downloadaports-e68b6f0a78703059b51798c790b5266260264df9.tar.bz2
aports-e68b6f0a78703059b51798c790b5266260264df9.tar.xz
main/linux-grsec: use flat memory model
It seems like grsec has issues with sparse mem model.
Diffstat (limited to 'testing')
-rw-r--r--testing/linux-grsec/APKBUILD4
-rw-r--r--testing/linux-grsec/kernelconfig.x8615
2 files changed, 9 insertions, 10 deletions
diff --git a/testing/linux-grsec/APKBUILD b/testing/linux-grsec/APKBUILD
index cdf77627fb..cecf3dfeb4 100644
--- a/testing/linux-grsec/APKBUILD
+++ b/testing/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.38.6
_kernver=2.6.38
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -141,5 +141,5 @@ md5sums="7d471477bfa67546f902da62227fa976 linux-2.6.38.tar.bz2
a43f9eec728708af59fa08ed0e0f3391 grsecurity-2.2.2-2.6.38.6-201105111839.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
aa1b82da0cabfb41c5e6da5bddf60bab net-gre-provide-multicast-mappings-for-ipv4-and-ipv6.patch
-b74a3d85ae51c53316297bd9d92c841f kernelconfig.x86
+ac8deebf46b61ae9dc041a013a5b80d4 kernelconfig.x86
0a73d8d896101de90f47dae32119e7ca kernelconfig.x86_64"
diff --git a/testing/linux-grsec/kernelconfig.x86 b/testing/linux-grsec/kernelconfig.x86
index 2914d7172b..b60d377609 100644
--- a/testing/linux-grsec/kernelconfig.x86
+++ b/testing/linux-grsec/kernelconfig.x86
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
-# Linux/i386 2.6.38.4 Kernel Configuration
-# Mon May 2 09:18:07 2011
+# Linux/i386 2.6.38.6 Kernel Configuration
+# Tue May 17 09:57:24 2011
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -382,19 +382,18 @@ CONFIG_PAGE_OFFSET=0xC0000000
CONFIG_HIGHMEM=y
# CONFIG_ARCH_PHYS_ADDR_T_64BIT is not set
# CONFIG_ARCH_DMA_ADDR_T_64BIT is not set
-CONFIG_NEED_NODE_MEMMAP_SIZE=y
CONFIG_ARCH_FLATMEM_ENABLE=y
CONFIG_ARCH_SPARSEMEM_ENABLE=y
CONFIG_ARCH_SELECT_MEMORY_MODEL=y
CONFIG_ILLEGAL_POINTER_VALUE=0
CONFIG_SELECT_MEMORY_MODEL=y
-# CONFIG_FLATMEM_MANUAL is not set
-CONFIG_SPARSEMEM_MANUAL=y
-CONFIG_SPARSEMEM=y
-CONFIG_HAVE_MEMORY_PRESENT=y
+CONFIG_FLATMEM_MANUAL=y
+# CONFIG_SPARSEMEM_MANUAL is not set
+CONFIG_FLATMEM=y
+CONFIG_FLAT_NODE_MEM_MAP=y
CONFIG_SPARSEMEM_STATIC=y
CONFIG_HAVE_MEMBLOCK=y
-# CONFIG_MEMORY_HOTPLUG is not set
+CONFIG_PAGEFLAGS_EXTENDED=y
CONFIG_SPLIT_PTLOCK_CPUS=4
CONFIG_COMPACTION=y
CONFIG_MIGRATION=y