aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorPaper <paper@tilde.institute>2020-03-29 20:18:50 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-03-29 19:43:35 +0000
commite9fe6ad8a7124cba1a0fc93c938edf9a09447385 (patch)
treefd085f06c253915deb5d69e668c5ee79540efa4d /testing
parenta4c222a5248407f1f9b376a3f9aeda6e72731392 (diff)
downloadaports-e9fe6ad8a7124cba1a0fc93c938edf9a09447385.tar.bz2
aports-e9fe6ad8a7124cba1a0fc93c938edf9a09447385.tar.xz
testing/epub2txt: new aport
https://github.com/kevinboone/epub2txt2 CLI utility for extracting text from EPUB documents
Diffstat (limited to 'testing')
-rw-r--r--testing/epub2txt/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/epub2txt/APKBUILD b/testing/epub2txt/APKBUILD
new file mode 100644
index 0000000000..307d26a78a
--- /dev/null
+++ b/testing/epub2txt/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Paper <paper@tilde.institute>
+# Maintainer: Paper <paper@tilde.institute>
+pkgname=epub2txt
+pkgver=2.01
+pkgrel=0
+pkgdesc="CLI utility for extracting text from EPUB documents"
+url="https://github.com/kevinboone/epub2txt2"
+arch="all"
+license="GPL-3.0-only"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kevinboone/epub2txt2/archive/v$pkgver.tar.gz"
+options='!check' #no testsuite
+builddir="$srcdir/$pkgname"2"-$pkgver"
+
+build() {
+ make
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="87796e94cfa76380cd901f7c3ce7a09ebe510771966980a15df91df78330eab57453d83c2bfe4a2e502040f1809d0e1b0f8ef135597222f99495b81bde4ebe41 epub2txt-2.01.tar.gz"