aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorStefan Wagner <stw@bit-strickerei.de>2016-05-23 00:15:05 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-03 08:56:41 +0000
commiteb78dbda037b105d2ccbb71f8057964a5a9aef2e (patch)
treee99d056e99d97229a9266dda4901fafdce5a5786 /testing
parent25d748e1bb0defd56907586625a4e2888f521141 (diff)
downloadaports-eb78dbda037b105d2ccbb71f8057964a5a9aef2e.tar.bz2
aports-eb78dbda037b105d2ccbb71f8057964a5a9aef2e.tar.xz
testing/avrdude: new aport
Download/upload/manipulate the ROM and EEPROM contents of AVR microcontrollers http://www.nongnu.org/avrdude/
Diffstat (limited to 'testing')
-rw-r--r--testing/avrdude/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/avrdude/APKBUILD b/testing/avrdude/APKBUILD
new file mode 100644
index 0000000000..e77b1e920f
--- /dev/null
+++ b/testing/avrdude/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Stefan Wagner <stw@bit-strickerei.de>
+# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
+pkgname=avrdude
+pkgver=6.3
+pkgrel=0
+pkgdesc="Download/upload/manipulate the ROM and EEPROM contents of AVR microcontrollers"
+url="http://www.nongnu.org/avrdude/"
+arch="all"
+license="GPL"
+makedepends="linux-headers bash flex byacc libftdi1-dev libusb-compat-dev libelf-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.savannah.gnu.org/releases/avrdude/${pkgname}-${pkgver}.tar.gz"
+
+builddir="$srcdir/${pkgname}-${pkgver}"
+build() {
+ cd "$builddir"
+ ./configure \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-linuxgpio || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="58bb42049122cf80fe4f4d0ce36d92ee avrdude-6.3.tar.gz"
+sha256sums="0f9f731b6394ca7795b88359689a7fa1fba818c6e1d962513eb28da670e0a196 avrdude-6.3.tar.gz"
+sha512sums="b671008388d6a552e71066fec46429bc7f6639e8eac41113bcbba5a56212b78be31fcf04956b31e11c6b14888b0f6e825f7458395b9ff4fc28406074c7ded2b2 avrdude-6.3.tar.gz"