aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:45:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-03 07:45:43 +0000
commitec38a1cb23de8be3e23f0d9ae51030563da6ca63 (patch)
treef9ba378ebf213e3efa52a9213d85003c9a47fc6e /testing
parent96813504f80856d8d85b390207621e5cbba64a85 (diff)
downloadaports-ec38a1cb23de8be3e23f0d9ae51030563da6ca63.tar.bz2
aports-ec38a1cb23de8be3e23f0d9ae51030563da6ca63.tar.xz
testing/fprobe: use separate package() function
Diffstat (limited to 'testing')
-rw-r--r--testing/fprobe/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/fprobe/APKBUILD b/testing/fprobe/APKBUILD
index ea6faea284..824129afe5 100644
--- a/testing/fprobe/APKBUILD
+++ b/testing/fprobe/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=fprobe
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="libpcap-based tool that collect network traffic"
url="http://fprobe.sourceforge.net/"
license="GPL"
@@ -13,14 +13,18 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
$pkgname.initd
$pkgname.confd"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname