aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-10 21:27:11 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-10 19:34:54 +0000
commitec6a0c88681b55a30aa0d9ea71f6e8fc284fc89a (patch)
treee37df35e54186f78e423e92a210771af415fd7ad /testing
parent15539fa33ad48953a292925c32ef32ac3c65ab7b (diff)
downloadaports-ec6a0c88681b55a30aa0d9ea71f6e8fc284fc89a.tar.bz2
aports-ec6a0c88681b55a30aa0d9ea71f6e8fc284fc89a.tar.xz
testing/py3-wikipedia: upgrade to 1.4.5
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-wikipedia/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/testing/py3-wikipedia/APKBUILD b/testing/py3-wikipedia/APKBUILD
index 7459f594cb..302ede8919 100644
--- a/testing/py3-wikipedia/APKBUILD
+++ b/testing/py3-wikipedia/APKBUILD
@@ -1,27 +1,28 @@
# Contributor: Bart Ribberse <bribbers@disroot.org>
# Maintainer: Bart Ribberse <bribbers@disroot.org>
pkgname=py3-wikipedia
-pkgver=1.4.0
+pkgver=1.4.5
pkgrel=0
pkgdesc="Wikipedia API for Python"
-url="https://github.com/goldsmith/Wikipedia"
+url="https://github.com/barrust/Wikipedia"
arch="noarch"
license="MIT"
depends="python3 py3-beautifulsoup4 py-requests"
makedepends="py3-setuptools"
-source="https://pypi.python.org/packages/source/w/wikipedia/wikipedia-$pkgver.tar.gz"
-builddir="$srcdir/wikipedia-$pkgver"
+source="https://github.com/barrust/wikipedia/archive/v$pkgver/wikipedia-v$pkgver.tar.gz"
+options="net"
+builddir="$srcdir/Wikipedia-$pkgver"
build() {
python3 setup.py build
}
check() {
- python3 -m unittest discover tests/ '*test.py'
+ python3 setup.py test
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="56d3382c784fd16205edc5b6f34a8bac5b6fefc21856993413ba339e9e9016b9b65602ed8eaeb1fe593f8eafc6b7b049dba14427cf08e08aabc03fd971504418 wikipedia-1.4.0.tar.gz"
+sha512sums="1d5f95f568ef4f479f16416d5474db5ce1bf5588a4d30c51d22fea6dd9d052ee0176829cf60e3c720fcb20fd862bae21d320407b370fdfe0a7d468b770d37735 wikipedia-v1.4.5.tar.gz"