aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-25 20:14:18 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-25 20:15:35 +0000
commitee2490bc6c2227f3afc6a6227339361d6ef994b2 (patch)
tree4b6a6457d57d4ec874be76d384fb4caba3c2b0db /testing
parent56905f47f8e6b32dd1487cb71d6c7739b39d085e (diff)
downloadaports-ee2490bc6c2227f3afc6a6227339361d6ef994b2.tar.bz2
aports-ee2490bc6c2227f3afc6a6227339361d6ef994b2.tar.xz
testing/afl: Remove amd64 binaries on ppc64le package
Currently afl is packaging an Intel binary inside the ppc64le package, which causes a failure in the strip() process. This patch remove this file from the final package.
Diffstat (limited to 'testing')
-rw-r--r--testing/afl/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/afl/APKBUILD b/testing/afl/APKBUILD
index c3ae502831..443666117d 100644
--- a/testing/afl/APKBUILD
+++ b/testing/afl/APKBUILD
@@ -31,6 +31,10 @@ package() {
# portable to non-x86 platforms.
rm -f "$pkgdir/usr/bin/afl-clang" "$pkgdir/usr/bin/afl-clang++" \
"$pkgdir/usr/bin/afl-gcc" "$pkgdir/usr/bin/afl-g++"
+
+ if [ "$CARCH" = "ppc64le" ]; then
+ rm -f "$pkgdir"/usr/share/afl/testcases/others/elf/small_exec.elf
+ fi
}
sha512sums="e1af6e6c4dedcc3f7f17857bf45a2efeb64bdc51633003c5bd700c51eb30c72f1f4e7fed5f6570ec98ccbd22b54dbcf08cc3faec4d28004fe0fa863a4d7ea90f afl-2.41b.tgz"