aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorAndreas Laghamn <andreas.laghamn@gmail.com>2018-02-09 11:46:53 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-03-30 07:14:49 +0300
commitef03517cdc2d4ffe4a1ab2051baa62fcba6810b0 (patch)
treed5078e95504bbea75e1c61b0eee275c496e3cdbc /testing
parent29f90c6cef9b27a2cffb1efaabc9e001cb2010ac (diff)
downloadaports-ef03517cdc2d4ffe4a1ab2051baa62fcba6810b0.tar.bz2
aports-ef03517cdc2d4ffe4a1ab2051baa62fcba6810b0.tar.xz
testing/cppzmq: new aport
https://github.com/zeromq/cppzmq High-level C++ binding for ZeroMQ
Diffstat (limited to 'testing')
-rw-r--r--testing/cppzmq/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/cppzmq/APKBUILD b/testing/cppzmq/APKBUILD
new file mode 100644
index 0000000000..1738f55535
--- /dev/null
+++ b/testing/cppzmq/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Andreas Laghamn <andreas.laghamn@gmail.com>
+# Maintainer: Andreas Laghamn <andreas.laghamn@gmail.com>
+pkgname=cppzmq
+pkgver=4.2.3
+pkgrel=0
+pkgdesc="High-level C++ binding for ZeroMQ"
+url="https://github.com/zeromq/cppzmq"
+arch="noarch"
+license="MIT"
+options="!check" # No test suite
+makedepends="cmake zeromq-dev"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/zeromq/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="462730e81c275bfbd7e39a8299ca9e202e6cc74e08074a161976e3bc92d54f4ae1d01e4d19c9b453bee6fed14921e9a207222c646085535e8a94872751551fc3 cppzmq-4.2.3.tar.gz"