aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-01-20 08:34:22 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-01-20 08:45:45 +0200
commitf20324ad254a03a3c895cb228465cd53719479cc (patch)
treed757ef472ad6a9ee0237a065d22138831f82abdb /testing
parentc605b8d016348905f7823b0def075fe29ef226c5 (diff)
downloadaports-f20324ad254a03a3c895cb228465cd53719479cc.tar.bz2
aports-f20324ad254a03a3c895cb228465cd53719479cc.tar.xz
testing/ecryptfs-utils: moved from unmaintained
- update to version 111, and update patch - modernize aport - take maintainership
Diffstat (limited to 'testing')
-rw-r--r--testing/ecryptfs-utils/APKBUILD47
-rw-r--r--testing/ecryptfs-utils/fix-build.patch11
2 files changed, 58 insertions, 0 deletions
diff --git a/testing/ecryptfs-utils/APKBUILD b/testing/ecryptfs-utils/APKBUILD
new file mode 100644
index 0000000000..a4bace0b05
--- /dev/null
+++ b/testing/ecryptfs-utils/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: k0r10n <k0r10n.dev@gmail.com>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=ecryptfs-utils
+pkgver=111
+pkgrel=0
+pkgdesc="Enterprise-class stacked cryptographic filesystem for Linux"
+url="https://launchpad.net/ecryptfs"
+arch="all"
+license="GPL"
+depends="cryptsetup rsync"
+depends_dev="keyutils-dev linux-pam-dev nss-dev linux-headers"
+makedepends="$depends_dev swig intltool gettext python"
+install=""
+options="suid"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://launchpad.net/ecryptfs/trunk/${pkgver}/+download/${pkgname}_${pkgver}.orig.tar.gz
+ fix-build.patch
+ "
+
+builddir="$srcdir"/${pkgname}-${pkgver}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" rootsbindir='/usr/bin' install || return 1
+ chmod +s "$pkgdir"/usr/bin/mount.ecryptfs_private || return 1
+}
+
+md5sums="83513228984f671930752c3518cac6fd ecryptfs-utils_111.orig.tar.gz
+d42bb467a5912df0d2e83e9fdd2553dd fix-build.patch"
+sha256sums="112cb3e37e81a1ecd8e39516725dec0ce55c5f3df6284e0f4cc0f118750a987f ecryptfs-utils_111.orig.tar.gz
+7f1038542a3aaba0cf5dd898f2e6e2ffbb9792fecff1a4eb532bb8bc39907fb9 fix-build.patch"
+sha512sums="d8643f3a1f9981fecc6a08b4aa0adb6272e7340db794f6e7507cba7b712247c6beb239f27875eab6e38a69b45bc2476e6bf6b4485eb82d58f65cc469f8613c18 ecryptfs-utils_111.orig.tar.gz
+09ff196e6d3ef54ef57e22e78a4af748c2989928a5c8bc3ece1f8c21c5f301b7e56142c5098111ac853ac88c1b2ee2d0b5c606a210fb53cdf0fde534aa0af92f fix-build.patch"
diff --git a/testing/ecryptfs-utils/fix-build.patch b/testing/ecryptfs-utils/fix-build.patch
new file mode 100644
index 0000000000..6758fdb5b5
--- /dev/null
+++ b/testing/ecryptfs-utils/fix-build.patch
@@ -0,0 +1,11 @@
+--- ecryptfs-utils-111.orig/src/utils/mount.ecryptfs_private.c 2016-01-22 18:04:52.000000000 +0200
++++ ecryptfs-utils-111/src/utils/mount.ecryptfs_private.c 2017-01-20 08:39:31.877975729 +0200
+@@ -235,7 +235,7 @@
+ * deceive other programs with a crafted /proc/self/*. See
+ * https://launchpad.net/bugs/1530566 for more details.
+ */
+- __SWORD_TYPE f_type_whitelist[] = {
++ static const uint32_t f_type_whitelist[] = {
+ 0x61756673 /* AUFS_SUPER_MAGIC */,
+ 0x9123683E /* BTRFS_SUPER_MAGIC */,
+ 0x00C36400 /* CEPH_SUPER_MAGIC */,