aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2012-06-08 06:58:18 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2012-06-08 07:00:49 +0000
commitf52a9e4b9ddff4e5b3c633a11fe74639e595c533 (patch)
tree94ab07d503502cc6ce91fda8707035f6f9b9b5ee /testing
parent67844c597d4ebe29f66ea5b1deef9484541fee9e (diff)
downloadaports-f52a9e4b9ddff4e5b3c633a11fe74639e595c533.tar.bz2
aports-f52a9e4b9ddff4e5b3c633a11fe74639e595c533.tar.xz
testing/py-ethtool: move to main
Diffstat (limited to 'testing')
-rw-r--r--testing/py-ethtool/APKBUILD44
-rw-r--r--testing/py-ethtool/python-ethtool-libnl-1.0-support.patch71
2 files changed, 0 insertions, 115 deletions
diff --git a/testing/py-ethtool/APKBUILD b/testing/py-ethtool/APKBUILD
deleted file mode 100644
index de58b1ea59..0000000000
--- a/testing/py-ethtool/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
-pkgname=py-ethtool
-_realname=python-ethtool
-pkgver=0.7
-pkgrel=0
-pkgdesc="Python library for the ethtool kernel interface"
-url="http://www.ohloh.net/p/python-ethtool"
-arch="all"
-license="GPL"
-depends=
-depends_dev="libnl-dev pkgconfig python-dev"
-makedepends="$depends_dev"
-install=
-subpackages=
-source="http://dsommers.fedorapeople.org/python-ethtool/$_realname-$pkgver.tar.bz2
- python-ethtool-libnl-1.0-support.patch"
-
-
-_builddir="$srcdir"/$_realname-$pkgver
-
-prepare() {
- cd "$_builddir"
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- return 0
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
- # python setup.py install --root="$pkgdir"
-}
-
-md5sums="2d13e2412948344b8375f5af4ced1c20 python-ethtool-0.7.tar.bz2
-188f260534eb838193e0e8c249b6a33c python-ethtool-libnl-1.0-support.patch"
diff --git a/testing/py-ethtool/python-ethtool-libnl-1.0-support.patch b/testing/py-ethtool/python-ethtool-libnl-1.0-support.patch
deleted file mode 100644
index 43c53dba4e..0000000000
--- a/testing/py-ethtool/python-ethtool-libnl-1.0-support.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-diff --git a/python-ethtool/etherinfo.c b/python-ethtool/etherinfo.c
-index 3d2072b..23f03c6 100644
---- a/python-ethtool/etherinfo.c
-+++ b/python-ethtool/etherinfo.c
-@@ -30,6 +30,52 @@
- #include "etherinfo_struct.h"
- #include "etherinfo.h"
-
-+#ifdef LIBNL_1_0
-+#define NLHDR_COMMON \
-+ int ce_refcnt; \
-+ struct nl_object_ops * ce_ops; \
-+ struct nl_cache * ce_cache; \
-+ struct nl_list_head ce_list; \
-+ int ce_msgtype; \
-+ int ce_flags; \
-+ uint32_t ce_mask;
-+
-+struct nl_cache
-+{
-+ struct nl_list_head c_items;
-+ int c_nitems;
-+ int c_iarg1;
-+ int c_iarg2;
-+ struct nl_cache_ops * c_ops;
-+};
-+
-+struct nl_object
-+{
-+ NLHDR_COMMON
-+};
-+
-+void nl_cache_free(struct nl_cache *cache)
-+{
-+ struct nl_object *obj, *tmp;
-+
-+ if( !cache )
-+ return;
-+
-+ nl_list_for_each_entry_safe(obj, tmp, &cache->c_items, ce_list) {
-+ struct nl_cache *cache = obj->ce_cache;
-+ if( !cache ) {
-+ break;
-+ }
-+
-+ nl_list_del(&obj->ce_list);
-+ obj->ce_cache = NULL;
-+ nl_object_put(obj);
-+ cache->c_nitems--;
-+ }
-+ free(cache);
-+}
-+#endif
-+
- /*
- *
- * Internal functions for working with struct etherinfo
-diff --git a/setup.py b/setup.py
-index bde04dc..9adff64 100644
---- a/setup.py
-+++ b/setup.py
-@@ -67,7 +67,8 @@ setup(name='ethtool',
- include_dirs = libnl['include'],
- library_dirs = libnl['libdirs'],
- libraries = libnl['libs'],
-- define_macros = [('VERSION', '"%s"' % version)]
-+ define_macros = [('VERSION', '"%s"' % version),
-+ ('LIBNL_1_0', None)]
- )
- ]
- )