aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-11 14:50:54 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 15:18:54 +0000
commitf55f02836c1c99a815f30191557049b93b808167 (patch)
treee823cbf850a96f2468ba0c7a327874e61899a8c2 /testing
parent14f65b6fd3049eaed3cfe7a11a1d280c6a5ab991 (diff)
downloadaports-f55f02836c1c99a815f30191557049b93b808167.tar.bz2
aports-f55f02836c1c99a815f30191557049b93b808167.tar.xz
community/libimobiledevice: move from community
* Modernize APKBUILD * Fix license * Add two upstream patches, fixing OpenSSLv1.1.x build & runtime Closes GH-7597
Diffstat (limited to 'testing')
-rw-r--r--testing/libimobiledevice/01-libressl.patch38
-rw-r--r--testing/libimobiledevice/APKBUILD37
2 files changed, 0 insertions, 75 deletions
diff --git a/testing/libimobiledevice/01-libressl.patch b/testing/libimobiledevice/01-libressl.patch
deleted file mode 100644
index 616c0dce74..0000000000
--- a/testing/libimobiledevice/01-libressl.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 69c42078cc5512ba6ed9cbfd2644f501d59c0717 Mon Sep 17 00:00:00 2001
-From: vmanoilov <vladinc@gmail.com>
-Date: Mon, 21 Mar 2016 23:35:01 +0000
-Subject: [PATCH] Update idevice.c
-
----
- src/idevice.c | 16 +++++++++-------
- 1 file changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/src/idevice.c b/src/idevice.c
-index b776e84..b5c4407 100644
---- a/src/idevice.c
-+++ b/src/idevice.c
-@@ -676,14 +676,16 @@ LIBIMOBILEDEVICE_API idevice_error_t idevice_connection_enable_ssl(idevice_conne
- debug_info("ERROR: Could not create SSL bio.");
- return ret;
- }
-- BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
-
-- SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv3_method());
-- if (ssl_ctx == NULL) {
-- debug_info("ERROR: Could not create SSL context.");
-- BIO_free(ssl_bio);
-- return ret;
-- }
-+ BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
-+
-+ SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv23_method());
-+ if (ssl_ctx == NULL) {
-+ debug_info("ERROR: Could not create SSL context.");
-+ BIO_free(ssl_bio);
-+ return ret;
-+
-+ }
-
- BIO* membp;
- X509* rootCert = NULL;
-
diff --git a/testing/libimobiledevice/APKBUILD b/testing/libimobiledevice/APKBUILD
deleted file mode 100644
index d03c66768e..0000000000
--- a/testing/libimobiledevice/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=libimobiledevice
-pkgver=1.2.0
-pkgrel=3
-pkgdesc="Library that talks the protocols to support iPhone and iPod Touch devices on Linux"
-url="http://libimobiledevice.org/"
-arch="all"
-license="GPL-2.0 LGPL-2.1"
-makedepends="gnutls-dev openssl-dev libgcrypt-dev libusbmuxd-dev
- libtasn1-dev libplist-dev libtool automake autoconf"
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://libimobiledevice.org/downloads/$pkgname-$pkgver.tar.bz2
- 01-libressl.patch"
-builddir="$srcdir"/$pkgname-$pkgver
-
-check() {
- cd "$builddir"
- make check
-}
-
-build() {
- cd "$builddir"
- ./configure \
- --prefix=/usr \
- --disable-static \
- --without-cython
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-}
-
-sha512sums="0de5f768aeb5d62445892855d84ceaff776f6667733c351ed6c34bf9d500802762d1a06e5efdf57f33cafc9ee788041cd9b6748fb9bad6c2e4ae2f9b9aa93589 libimobiledevice-1.2.0.tar.bz2
-74b05241aa8202aed02e33570c950c54319526b8906862b3624edc9e586992f3bdfbdad7d7b4e4334b8550b252bad82365f0e04a2b71d1f9f0a20269f40e4ce0 01-libressl.patch"