aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-04-22 08:39:14 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-04-22 08:39:18 +0000
commitfb2187317cd576c149c051f0ceef4e2b98c4effe (patch)
tree830588823f4a68af5b2dc1568fbfe620ee9fb0b1 /testing
parentfecb8c04999167ea3f26c6808dfb4ce5722acbec (diff)
downloadaports-fb2187317cd576c149c051f0ceef4e2b98c4effe.tar.bz2
aports-fb2187317cd576c149c051f0ceef4e2b98c4effe.tar.xz
testing/icingaweb2: added php dependencies
Diffstat (limited to 'testing')
-rw-r--r--testing/icingaweb2/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/testing/icingaweb2/APKBUILD b/testing/icingaweb2/APKBUILD
index b303996615..b5209494eb 100644
--- a/testing/icingaweb2/APKBUILD
+++ b/testing/icingaweb2/APKBUILD
@@ -2,12 +2,14 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=icingaweb2
pkgver=2.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Web Interface for Icinga2"
url="http://www.icinga.org"
arch="noarch"
license="GPL"
-depends="php php-gd php-ldap php-intl php-pgsql php-mysql php-gettext php-ctype icinga2"
+depends="icinga2 php php-gd php-ldap php-intl php-pgsql php-mysql
+ php-gettext php-ctype icinga2 php-openssl php-json php-dom
+ php-imagick php-pdo_mysql php-pdo_pgsql"
depends_dev=""
makedepends="$depends_dev"
pkggroups="www-data"
@@ -38,9 +40,8 @@ package() {
mkdir -p "$pkgdir/usr/share/webapps/$pkgname"
mkdir -p "$pkgdir/var/log/$pkgname"
mkdir -p "$pkgdir/usr/share/doc/$pkgname"
- cp -r application doc library modules public bin "$pkgdir"/usr/share/webapps/$pkgname
+ cp -r application doc library modules public bin etc "$pkgdir"/usr/share/webapps/$pkgname
ln -s /usr/share/webapps/icingaweb2/bin/icingacli "$pkgdir"/usr/bin/icingacli
- cp -r etc/schema "$pkgdir"/usr/share/$pkgname
chmod 2770 "$pkgdir"/etc/$pkgname
chmod 750 "$pkgdir"/var/log/$pkgname
chgrp -R $pkggroups "$pkgdir"/etc/$pkgname