aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/asunder
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/asunder
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/asunder')
-rw-r--r--unmaintained/asunder/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/asunder/APKBUILD b/unmaintained/asunder/APKBUILD
new file mode 100644
index 0000000000..05fc701d76
--- /dev/null
+++ b/unmaintained/asunder/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=asunder
+pkgver=2.3
+pkgrel=1
+pkgdesc="A graphical Audio CD ripper and encoder"
+url="http://littlesvr.ca/asunder"
+arch="all"
+license="GPL2"
+depends="cdparanoia"
+makedepends="libcddb-dev gtk+-dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://littlesvr.ca/asunder/releases/asunder-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/asunder-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="dd690d8f4c68a2e786c657e08be688d0 asunder-2.3.tar.bz2"
+sha256sums="ded2eff22c7e65f46eecd8ad89c6c37c5a032af280e293a59c3e5bb34c0bb05f asunder-2.3.tar.bz2"
+sha512sums="fdab3a7767b63d807d7a8d7bb590da0e2229c4da34eba92d3cde0b955aa3cb7a6f45081fe3616576bfd4ed7847aac56c580cb4ecaa9f3bdde9759dd1a75f777d asunder-2.3.tar.bz2"