aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/crunch/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/crunch/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/crunch/APKBUILD')
-rw-r--r--unmaintained/crunch/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/crunch/APKBUILD b/unmaintained/crunch/APKBUILD
new file mode 100644
index 0000000000..bdcd8051c8
--- /dev/null
+++ b/unmaintained/crunch/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=crunch
+pkgver=3.4
+pkgrel=0
+pkgdesc="A wordlist generator"
+url="http://sourceforge.net/projects/crunch-wordlist/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/crunch-wordlist/crunch-wordlist/$pkgname-$pkgver.tgz
+ crunch-3.4-destdir.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p2 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" geninstall || return 1
+}
+
+md5sums="3f658a60d8227025df12cfb4ff4b9e15 crunch-3.4.tgz
+a75466c9dae86223f913f622208eef86 crunch-3.4-destdir.patch"