aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/csync
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/csync
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/csync')
-rw-r--r--unmaintained/csync/APKBUILD71
-rw-r--r--unmaintained/csync/gcc-fixes.patch12
-rw-r--r--unmaintained/csync/iconv.patch26
3 files changed, 109 insertions, 0 deletions
diff --git a/unmaintained/csync/APKBUILD b/unmaintained/csync/APKBUILD
new file mode 100644
index 0000000000..7df5f5d65f
--- /dev/null
+++ b/unmaintained/csync/APKBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=csync
+pkgver=0.50.0
+pkgrel=0
+pkgdesc="a client only bidirectional file synchronizer"
+url="http://www.csync.org/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev check-dev samba-dev libssh-dev cmake sqlite-dev
+ iniparser-dev neon-dev"
+install=""
+subpackages="
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-sftp:_plugin
+ $pkgname-smb:_plugin
+ $pkgname-owncloud:_plugin"
+source="https://open.cryptomilk.org/attachments/download/27/csync-$pkgver.tar.xz
+ iconv.patch
+ gcc-fixes.patch"
+
+_builddir="$srcdir"/csync-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ mkdir build && cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ .. || return 1
+ make || return 1
+
+}
+
+package() {
+ cd "$_builddir"/build
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+_plugin() {
+ local _name="${subpkgname##*-}"
+ pkgdesc="csync $1 plugin"
+
+ local i
+ cd "$pkgdir"
+ for i in usr/lib/csync*/csync_${_name}.so; do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv $i "$subpkgdir"/${i%/*}
+ done
+}
+
+md5sums="4f022aaa19ecd8008b03876dd65a9df2 csync-0.50.0.tar.xz
+166e828bf574dbfc1857b04985ec699b iconv.patch
+70a120f5f913fb44f66844734e200131 gcc-fixes.patch"
+sha256sums="c07526942a93c1e213d354dc45fd61fbc0430c60e109e7a2f0fcaf6213a45c86 csync-0.50.0.tar.xz
+1a64b9ad6bc8c79b16ae8f6eb31ca2d3e124132e8130b908925d60ddc0eea98c iconv.patch
+1bb262390c687780dc65adb36f0c89c7c04d3db235d69d1cae9280c8c6029cae gcc-fixes.patch"
+sha512sums="babe44af3a4f0bf58e011f1c33c7a6df9bc7751e03714dd64d8269c7c51bcc7f2ab32c4d286e5a11465c9498c988d1812c426a4f415f1138a4fb9fa341e1e29a csync-0.50.0.tar.xz
+fc124966d7b7405cc3d3bc1276180089dc44058bc89afa799c0d9378f4dc131e9382b96357fff5964c9b009cb77455f125b63557a32ca5eaa31e01cbd2f7a694 iconv.patch
+88290d1dfbfeb775d89f4fbd20b9909a3fe5896ae85496eb53a0bd78162427ba7d910852ffb1887dcf380ad89e46c909d29e0a54f020c3ea92e613ac860b1b99 gcc-fixes.patch"
diff --git a/unmaintained/csync/gcc-fixes.patch b/unmaintained/csync/gcc-fixes.patch
new file mode 100644
index 0000000000..2614c974ea
--- /dev/null
+++ b/unmaintained/csync/gcc-fixes.patch
@@ -0,0 +1,12 @@
+diff -upr csync-0.50.0.orig/src/csync_log.h csync-0.50.0/src/csync_log.h
+--- csync-0.50.0.orig/src/csync_log.h 2015-09-29 19:44:49.692758996 +0200
++++ csync-0.50.0/src/csync_log.h 2015-09-29 19:45:48.439175389 +0200
+@@ -55,7 +55,7 @@ enum csync_log_priority_e {
+ };
+
+ #define CSYNC_LOG(priority, ...) \
+- csync_log(priority, __FUNCTION__, __VA_ARGS__)
++ csync_log(priority, __func__, __VA_ARGS__)
+
+ void csync_log(int verbosity,
+ const char *function,
diff --git a/unmaintained/csync/iconv.patch b/unmaintained/csync/iconv.patch
new file mode 100644
index 0000000000..fcafeb3a80
--- /dev/null
+++ b/unmaintained/csync/iconv.patch
@@ -0,0 +1,26 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1cc90bc..f8309dd 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -28,7 +28,7 @@ set(CSYNC_LINK_LIBRARIES
+ ${SQLITE3_LIBRARIES}
+ )
+
+-if(HAVE_ICONV AND WITH_ICONV)
++if(WITH_ICONV)
+ list(APPEND CSYNC_PRIVATE_INCLUDE_DIRS ${ICONV_INCLUDE_DIR})
+ list(APPEND CSYNC_LINK_LIBRARIES ${ICONV_LIBRARIES})
+ endif()
+diff --git a/src/std/c_string.c b/src/std/c_string.c
+index f175734..ccc0644 100644
+--- a/src/std/c_string.c
++++ b/src/std/c_string.c
+@@ -39,7 +39,7 @@
+ #include <windows.h>
+ #endif
+
+-#if defined(HAVE_ICONV) && defined(WITH_ICONV)
++#if defined(WITH_ICONV)
+ # ifdef HAVE_ICONV_H
+ # include <iconv.h>
+ # endif