aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/djvulibre
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/djvulibre
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/djvulibre')
-rw-r--r--unmaintained/djvulibre/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/djvulibre/APKBUILD b/unmaintained/djvulibre/APKBUILD
new file mode 100644
index 0000000000..d922a91d5c
--- /dev/null
+++ b/unmaintained/djvulibre/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Andrew Hills <ahills@ednos.net>
+# Maintainer: Andrew Hills <ahills@ednos.net>
+pkgname=djvulibre
+pkgver=3.5.27
+pkgrel=0
+pkgdesc="An open source implementation of DjVu"
+url="http://djvu.sourceforge.net"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/djvu/djvulibre-$pkgver.tar.gz"
+
+_builddir="$srcdir"/djvulibre-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="aa4ed331f669f5a72e3c0d7f9196c4e6 djvulibre-3.5.27.tar.gz"
+sha256sums="e69668252565603875fb88500cde02bf93d12d48a3884e472696c896e81f505f djvulibre-3.5.27.tar.gz"
+sha512sums="62abcaa2fe7edab536477929ba38b882453dab1a06e119a3f838b38d5c61f5d8c252e4769e6534582b826e49bcfb490513179580fab9c3afa84aa92053ccebee djvulibre-3.5.27.tar.gz"