aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/dmz-cursor-theme
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/dmz-cursor-theme
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/dmz-cursor-theme')
-rw-r--r--unmaintained/dmz-cursor-theme/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/unmaintained/dmz-cursor-theme/APKBUILD b/unmaintained/dmz-cursor-theme/APKBUILD
new file mode 100644
index 0000000000..1b92ea8ae7
--- /dev/null
+++ b/unmaintained/dmz-cursor-theme/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: August Klein <amatcoder@gmail.com>
+pkgname=dmz-cursor-theme
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="DMZ cursor theme"
+url="http://jimmac.musichall.cz"
+arch="noarch"
+license="CC-BY-SA"
+depends=""
+depends_dev=""
+makedepends="xcursorgen"
+install=""
+subpackages="dmz-aa-cursor-theme:aa"
+source="http://ftp.de.debian.org/debian/pool/main/d/$pkgname/"$pkgname"_"$pkgver".tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"/DMZ-White/pngs
+ ./make.sh || return 1
+ cd "$_builddir"/DMZ-Black/pngs
+ ./make.sh || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/share/icons/Vanilla-DMZ/cursors || return 1
+ cp -a DMZ-White/xcursors/* "$pkgdir"/usr/share/icons/Vanilla-DMZ/cursors || return 1
+ install -Dm644 DMZ-White/index.theme "$pkgdir"/usr/share/icons/Vanilla-DMZ/index.theme
+}
+
+aa() {
+ cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/share/icons/Vanilla-DMZ-AA/cursors || return 1
+ cp -a DMZ-Black/xcursors/* "$subpkgdir"/usr/share/icons/Vanilla-DMZ-AA/cursors || return 1
+ install -Dm644 DMZ-Black/index.theme "$subpkgdir"/usr/share/icons/Vanilla-DMZ-AA/index.theme
+}
+
+md5sums="06fbab13df89c5770ce61b0e3e31e5f6 dmz-cursor-theme_0.4.4.tar.gz"
+sha256sums="46af4cf1356df799f9ee94451f05d0bdbb8d82e54bdeae3f32fa107602359981 dmz-cursor-theme_0.4.4.tar.gz"
+sha512sums="e0f455e3b66c0acb87eb9f017e7d7e6e16782a58c8c3a3518c879d1251372beaf92bdf87775ee72ff6eb477385f4f58e6d00479967d634337c5fae766179a5d3 dmz-cursor-theme_0.4.4.tar.gz"