aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/embryo
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/embryo
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/embryo')
-rw-r--r--unmaintained/embryo/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/embryo/APKBUILD b/unmaintained/embryo/APKBUILD
new file mode 100644
index 0000000000..60b6b97d0c
--- /dev/null
+++ b/unmaintained/embryo/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=embryo
+pkgver=1.7.9
+pkgrel=0
+pkgdesc="Enlightenment's virtual machine engine and bytecode compiler"
+url="http://trac.enlightenment.org/e/wiki/Embryo"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="eina-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/embryo-$pkgver.tar.gz"
+
+_builddir="$srcdir"/embryo-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="98614ec48376ff6d3a39187504b70ed4 embryo-1.7.9.tar.gz"
+sha256sums="6b2739a53c3ab2fcf44edfb9c3a4c56d11aba91e27e556a9e70116a161201e34 embryo-1.7.9.tar.gz"
+sha512sums="4fb1f5f81dd79d668a395162098ee43f8301b20dcb8260471b28e6a8ca95a89232fe3ab97754522423e7a3a8c344133b4a83100200b3c914ee67a3dd41ae2361 embryo-1.7.9.tar.gz"