aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/freealut
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/freealut
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/freealut')
-rw-r--r--unmaintained/freealut/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/freealut/APKBUILD b/unmaintained/freealut/APKBUILD
new file mode 100644
index 0000000000..e51fcecb35
--- /dev/null
+++ b/unmaintained/freealut/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=freealut
+pkgver=1.1.0
+pkgrel=2
+pkgdesc="A free audio library user toolkit"
+url="https://github.com/vancegroup/freealut"
+arch="all"
+license="GPL2"
+depends=
+depends_dev="openal-soft-dev"
+makedepends="$depends_dev autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev"
+source="https://github.com/vancegroup/freealut/archive/freealut_${pkgver//./_}.tar.gz"
+
+_builddir="$srcdir"/freealut-freealut_${pkgver//./_}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="66e21cb1d2aee23f587d9304ac6cbddc freealut_1_1_0.tar.gz"
+sha256sums="c3880d7dbb90c7db54e1d6b88aa0a34dd9e2d828fd389be0d2cbb2632b0885dd freealut_1_1_0.tar.gz"
+sha512sums="c9dead230434b3916f91e219913c2b2c877c4594d74b63641246a6704e28fe8d415131127cc00b51355f2fdf4e2bbf8aaf2b802fec479b05927e39a8698c251e freealut_1_1_0.tar.gz"