aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/gcalcli
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-04-04 10:52:14 +0100
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-12 10:12:33 +0000
commit44d63ad282eb051f8f5b9c0bd04260dbc8003e27 (patch)
tree62c24f5de0dca8e41c40a40510c625733bbc2d65 /unmaintained/gcalcli
parent0158bbbed9eeeecb95ebb3318d1809f31b9c4df1 (diff)
downloadaports-44d63ad282eb051f8f5b9c0bd04260dbc8003e27.tar.bz2
aports-44d63ad282eb051f8f5b9c0bd04260dbc8003e27.tar.xz
unmaintained/gcalcli: move from main/
Moved temporarily during upgrade from Python 3.6 to 3.7 for the reasons listed below after a discussion [1]: - This package has no maintainer. - The current APKBUILD mixes Python 2 and 3 - The latest version (4.0.4) has a dependency on py3-parsedatetime which is in community/ not main/ - The dependency py-google-api-python-client requires google-auth-httplib2 which is not yet packaged: $ gcalcli -h ✂ pkg_resources.DistributionNotFound: The 'google-auth-httplib2>=0.0.3' distribution was not found and is required by google-api-python-client [1] https://github.com/alpinelinux/aports/pull/6934#issuecomment-479827121
Diffstat (limited to 'unmaintained/gcalcli')
-rw-r--r--unmaintained/gcalcli/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/unmaintained/gcalcli/APKBUILD b/unmaintained/gcalcli/APKBUILD
new file mode 100644
index 0000000000..413b5a197f
--- /dev/null
+++ b/unmaintained/gcalcli/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer:
+pkgname=gcalcli
+pkgver=3.4.0
+pkgrel=1
+pkgdesc="Google Calendar Command Line Interface"
+url="https://github.com/insanum/gcalcli"
+arch="noarch"
+license="MIT"
+depends="python3 py-google-api-python-client py-dateutil py-gflags py-vobject"
+makedepends="python2-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/insanum/$pkgname/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d3844dc34dfd21b1cca6f46bf2b66b6aabfccd4d7b23ad4e076966aeec51681792c0dbe5f61e4cb84a75ce3bbf4fd1c63a2ce759cecdeee3e4608c0238c07a4b gcalcli-3.4.0.tar.gz"