aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/grantlee
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/grantlee
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/grantlee')
-rw-r--r--unmaintained/grantlee/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/grantlee/APKBUILD b/unmaintained/grantlee/APKBUILD
new file mode 100644
index 0000000000..452d1c8fd5
--- /dev/null
+++ b/unmaintained/grantlee/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor:k0r10n <k0r10n.dev@gmail.com>
+# Maintainer:
+pkgname=grantlee
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Grantlee is a set of free software libraries written using the Qt framework"
+url="http://www.gitorious.org/grantlee/pages/Home"
+arch="all"
+license="LGPL3"
+depends=
+depends_dev="cmake qt-dev doxygen"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://downloads.grantlee.org/${pkgname}-${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir -p "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="fa8a2e9be7be7e3a89e700679e6f3014 grantlee-0.4.0.tar.gz"
+sha256sums="13a2d8121392404bb3be4ed470b211bc098cd98da795ef7bf41517d2fb640d3f grantlee-0.4.0.tar.gz"
+sha512sums="6ff539eb7aaf366487214b02131d67b9967713c42d20314ff56129e9543516fdf2d129b9c3015f0959c89c6f0ee9ad085af91fed4293bd0613d8e888bc850ca7 grantlee-0.4.0.tar.gz"