aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/httest
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/httest
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/httest')
-rw-r--r--unmaintained/httest/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/unmaintained/httest/APKBUILD b/unmaintained/httest/APKBUILD
new file mode 100644
index 0000000000..d1686311a5
--- /dev/null
+++ b/unmaintained/httest/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=httest
+pkgver=2.4.12
+pkgrel=0
+pkgdesc="A script based tool for testing and benchmarking web applications"
+url="http://htt.sourceforge.net"
+arch="all"
+license="ASL 2.0"
+depends=""
+depends_dev=""
+makedepends="apr-dev apr-util-dev pcre-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/project/htt/htt2.4/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ update_config_sub || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="6ef11879e714739b55ebc314c9ed889b httest-2.4.12.tar.gz"
+sha256sums="fd18cdc996c199d56d77e9355c07e1e1701d5550c03fbecb06a255ce72d79bd1 httest-2.4.12.tar.gz"
+sha512sums="a8253b7eb5fa544f279cba5825d1485f571398ec4646c012ed697fe870e42809bf6f14454b865ad59a50864cb5367c53afc614941318e130d9948f1499c2985f httest-2.4.12.tar.gz"