aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/httpry
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/httpry
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/httpry')
-rw-r--r--unmaintained/httpry/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/unmaintained/httpry/APKBUILD b/unmaintained/httpry/APKBUILD
new file mode 100644
index 0000000000..0687dbf725
--- /dev/null
+++ b/unmaintained/httpry/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=httpry
+pkgver=0.1.8
+pkgrel=0
+pkgdesc="A packet sniffer designed for HTTP traffic"
+url="http://dumpsterventures.com/jason/httpry/"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://dumpsterventures.com/jason/httpry/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -m755 -D "$_builddir"/$pkgname \
+ "$pkgdir"/usr/sbin/$pkgname || return 1
+ install -m644 -D "$_builddir"/$pkgname.1 \
+ "$pkgdir"/usr/share/man/man1/$pkgname.1 || return 1
+}
+
+md5sums="212a03b32c3e3668f5890f8779a86ded httpry-0.1.8.tar.gz"
+sha256sums="ef53454f895f68005f7b9ab634d1b433c4df839eacea9109e4ee48d4296fb613 httpry-0.1.8.tar.gz"
+sha512sums="28d9fc37229e8b47711227762134e5b6e81bde0a44947f2e527771da2d042ba7e7c38b1ec205808a9e444e1235c91932ba16df4a31cc3d739c6474b25e149636 httpry-0.1.8.tar.gz"