aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/icli
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/icli
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/icli')
-rw-r--r--unmaintained/icli/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/unmaintained/icli/APKBUILD b/unmaintained/icli/APKBUILD
new file mode 100644
index 0000000000..4fc0d25fe4
--- /dev/null
+++ b/unmaintained/icli/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=icli
+_realname=App-Icli
+pkgver=0.48
+pkgrel=0
+pkgdesc="Icinga Command Line Interface"
+url="http://finalrewind.org/projects/App-Icli/"
+arch="noarch"
+license="custom"
+depends="perl-datetime perl-datetime-format-strptime perl-datetime-timezone
+ perl-list-moreutils perl-term-size"
+depends_dev=""
+makedepends="$depends_dev perl-module-build perl-test-compile
+ perl-test-pod perl-test-command"
+install=""
+subpackages="$pkgname-doc"
+source="http://finalrewind.org/projects/${_realname}/${_realname}-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$_realname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor destdir="${pkgdir}" \
+ --icli-object-file=/var/spool/icinga/objects.cache \
+ --icli-status-file=/var/spool/icinga/status.dat \
+ --icli-command-file=/var/spool/icinga/rw/icinga.cmd
+ ./Build
+}
+
+check() {
+ cd "$_builddir"
+ ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING
+}
+md5sums="bc8a49aa80784553cd880ecafe059597 App-Icli-0.48.tar.gz"
+sha256sums="f5dfd9c67a1e458d4d895be05d36e61f00b03eb8315e0942dbf6069593afb3ce App-Icli-0.48.tar.gz"
+sha512sums="b3f5b9a626a3eea9406f63cbb7c06e6415d57ca9c3cb2ad5890e182a385842d819cd35b186e16ed5d78ce1eeba32bba4f0cfb3abff401f292aa64dfbb46686bf App-Icli-0.48.tar.gz"