aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ipgrab/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ipgrab/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ipgrab/APKBUILD')
-rw-r--r--unmaintained/ipgrab/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/unmaintained/ipgrab/APKBUILD b/unmaintained/ipgrab/APKBUILD
new file mode 100644
index 0000000000..d808fdbf97
--- /dev/null
+++ b/unmaintained/ipgrab/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=ipgrab
+pkgver=0.9.8
+pkgrel=0
+pkgdesc="A verbose packet sniffer for hosts"
+url="http://ipgrab.sourceforge.net/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/ipgrab/ipgrab-$pkgver.tar.gz"
+
+_builddir="$srcdir"/ipgrab-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="73404aeee6e8c07b6b7d260ffe80b692 ipgrab-0.9.8.tar.gz"
+sha256sums="f56c2be55fa42f0a508a83d99349834aaaaab7ad2f2fd73504b9e17b999b7901 ipgrab-0.9.8.tar.gz"
+sha512sums="d796c65bb4e0b2f71fc8c91dd257ea654bff514fd8f6efcc1bc4b733be21e91e2d6facc3c1867750ea6416bbbd1835e51d8c923f83abd955f8aa62b972414ca7 ipgrab-0.9.8.tar.gz"