aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ipvsadm
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ipvsadm
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ipvsadm')
-rw-r--r--unmaintained/ipvsadm/APKBUILD46
-rw-r--r--unmaintained/ipvsadm/ipvsadm.initd42
2 files changed, 88 insertions, 0 deletions
diff --git a/unmaintained/ipvsadm/APKBUILD b/unmaintained/ipvsadm/APKBUILD
new file mode 100644
index 0000000000..01a36b0011
--- /dev/null
+++ b/unmaintained/ipvsadm/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+pkgname=ipvsadm
+pkgver=1.27
+pkgrel=1
+pkgdesc="The IP Virtual Server administration utility"
+url="http://www.linuxvirtualserver.org/software/ipvs.html"
+arch="all"
+license="GPL2"
+depends=
+depends_dev="libnl-dev popt-dev"
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-doc"
+source="https://kernel.org/pub/linux/utils/kernel/ipvsadm/$pkgname-$pkgver.tar.xz
+ $pkgname.initd"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make -j1 BUILD_ROOT="$pkgdir" \
+ MANDIR=usr/share/man \
+ SBIN="$pkgdir/usr/sbin" \
+ INIT="$pkgdir/etc/init.d" \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 BUILD_ROOT="$pkgdir" \
+ MANDIR=usr/share/man \
+ SBIN="$pkgdir/usr/sbin" \
+ INIT="$pkgdir/etc/init.d" \
+ install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="9decaaaad2fd637ed06cffd954e66cf3 ipvsadm-1.27.tar.xz
+bebb015ea02ead2a84be2bd5af4eb74c ipvsadm.initd"
+sha256sums="d360fb4dcf591e0a8a918831e2c02b1dc03e3c17ee1e60d0d70de9455238b3f8 ipvsadm-1.27.tar.xz
+d18d70c39d5dff6325b7e21fbd61485384b642b15a0dfee935ec9b7d4b9f0b66 ipvsadm.initd"
+sha512sums="cf982b7981674c91d1b7516de7b55cf378b306ce4a53e13976b8eeb8610015c4fa4aa9d251bc4d329db8e05c1862863160af2d3c63b76263f290087cffdf1b80 ipvsadm-1.27.tar.xz
+43b2186f48f17d43524c1f4e9de06227c6d491845c466cf6f00214b74fcd5e181e8b855fef8c6fa78c62a924ee3cc3317099278f9656183de8678440bb070625 ipvsadm.initd"
diff --git a/unmaintained/ipvsadm/ipvsadm.initd b/unmaintained/ipvsadm/ipvsadm.initd
new file mode 100644
index 0000000000..17a4bfac5e
--- /dev/null
+++ b/unmaintained/ipvsadm/ipvsadm.initd
@@ -0,0 +1,42 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/files/ipvsadm-init,v 1.5 2011/12/04 10:40:20 swegener Exp $
+
+extra_commands="save"
+
+depend() {
+ need net
+}
+
+checkconfig() {
+
+ checkpath --directory /var/lib/ipvsadm
+
+ if [ ! -f /var/lib/ipvsadm/rules-save ] ; then
+ eerror "Not starting ipvsadm. First create some rules then run"
+ eerror "/etc/init.d/ipvsadm save"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ipvsadm"
+ einfo "Clearing previous rules"
+ ipvsadm -C
+ ipvsadm-restore < /var/lib/ipvsadm/rules-save
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ipvsadm"
+ eend $?
+}
+
+save() {
+ ebegin "Saving ipvsadm state"
+ ipvsadm-save > /var/lib/ipvsadm/rules-save
+ eend $?
+}
+