aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libamz
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libamz
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libamz')
-rw-r--r--unmaintained/libamz/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/libamz/APKBUILD b/unmaintained/libamz/APKBUILD
new file mode 100644
index 0000000000..e7ba03378e
--- /dev/null
+++ b/unmaintained/libamz/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=libamz
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="library and tools for accessing amazon mp3 download queues"
+url="http://nenolod.net/projects/libamz"
+arch="all"
+license="ISC"
+depends=
+makedepends="libgcrypt-dev libsoup-dev libxml2-dev gtk+-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://nenolod.net/~nenolod/distfiles/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # workaround bug in busybox
+ sed -e "/touch/s/0001010000/200001010000/g" \
+ -i configure
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="fcecea69be7b62aa6d31b80b23e8f0db libamz-0.0.2.tar.bz2"