aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libc++/no-libunwind-sources.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-12 19:04:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-12 19:04:46 +0000
commit7b958a9fb9900c1447c577cc16a838177b2ad647 (patch)
tree65bcda2596292afbd5c0b94631e9d397d743bfc8 /unmaintained/libc++/no-libunwind-sources.patch
parent5d9a3ff79d1bd8fe3e7e296e62efb6de2d96bcd4 (diff)
downloadaports-7b958a9fb9900c1447c577cc16a838177b2ad647.tar.bz2
aports-7b958a9fb9900c1447c577cc16a838177b2ad647.tar.xz
testing/libc++: move to unmaintained
Diffstat (limited to 'unmaintained/libc++/no-libunwind-sources.patch')
-rw-r--r--unmaintained/libc++/no-libunwind-sources.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/libc++/no-libunwind-sources.patch b/unmaintained/libc++/no-libunwind-sources.patch
new file mode 100644
index 0000000000..d9c31051b5
--- /dev/null
+++ b/unmaintained/libc++/no-libunwind-sources.patch
@@ -0,0 +1,44 @@
+Shiz created this revision.
+Herald added a subscriber: mgorny.
+
+As per r241993, libunwind_ext.h is not used anymore, and thus only the public libunwind includes are needed.
+This eases distro packaging efforts and removes an unneeded requirement for out-of-tree building.
+
+
+Repository:
+ rL LLVM
+
+https://reviews.llvm.org/D33178
+
+Files:
+ libcxxabi/CMakeLists.txt
+
+
+Index: libcxxabi/CMakeLists.txt
+===================================================================
+--- a/libcxxabi/CMakeLists.txt
++++ b/libcxxabi/CMakeLists.txt
+@@ -459,23 +459,7 @@
+ NO_DEFAULT_PATH
+ )
+
+- find_path(
+- LIBCXXABI_LIBUNWIND_SOURCES
+- libunwind_ext.h
+- PATHS ${LIBCXXABI_LIBUNWIND_PATH}/src/
+- ${LIBCXXABI_LIBUNWIND_INCLUDES}/../src/
+- ${LLVM_MAIN_SRC_DIR}/projects/libunwind/src/
+- ${LLVM_MAIN_SRC_DIR}/runtimes/libunwind/src/
+- NO_DEFAULT_PATH
+- )
+-
+- if (LIBCXXABI_LIBUNWIND_SOURCES STREQUAL "LIBCXXABI_LIBUNWIND_SOURCES-NOTFOUND")
+- message(WARNING "LIBCXXABI_LIBUNWIND_SOURCES was not specified and couldn't be infered.")
+- set(LIBCXXABI_LIBUNWIND_SOURCES "")
+- endif()
+-
+ include_directories("${LIBCXXABI_LIBUNWIND_INCLUDES_INTERNAL}")
+- include_directories("${LIBCXXABI_LIBUNWIND_SOURCES}")
+ endif()
+
+ # Add source code. This also contains all of the logic for deciding linker flags