aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/liblo
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/liblo
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/liblo')
-rw-r--r--unmaintained/liblo/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/liblo/APKBUILD b/unmaintained/liblo/APKBUILD
new file mode 100644
index 0000000000..c5f25e5a99
--- /dev/null
+++ b/unmaintained/liblo/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liblo
+pkgver=0.26
+pkgrel=0
+pkgdesc="Open Sound Control library"
+url="http://liblo.sourceforge.net"
+arch="all"
+license="LGPL2+"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev"
+source="http://download.sf.net/sourceforge/liblo/liblo-$pkgver.tar.gz"
+
+_builddir="$srcdir"/liblo-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-ipv6 \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="5351de14262560e15e7f23865293b16f liblo-0.26.tar.gz"