aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/libstrophe/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/libstrophe/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/libstrophe/APKBUILD')
-rw-r--r--unmaintained/libstrophe/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/unmaintained/libstrophe/APKBUILD b/unmaintained/libstrophe/APKBUILD
new file mode 100644
index 0000000000..6da6326f2f
--- /dev/null
+++ b/unmaintained/libstrophe/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=libstrophe
+pkgver=0.8.6
+pkgrel=0
+epoch=1
+pkgdesc='Simple, lightweight C library for writing XMPP clients'
+arch=all
+url='http://strophe.im/libstrophe/'
+license='MIT'
+depends=
+makedepends='openssl-dev expat-dev check-dev autoconf automake libtool'
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/strophe/libstrophe/archive/$pkgver.tar.gz"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./bootstrap.sh || return 1
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make check || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 MIT-LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE-MIT
+}
+
+md5sums="5ab28dc86c47177819ca49ed9c0041e0 libstrophe-0.8.6.tar.gz"
+sha256sums="a2158134381e544a7697e9379f45abe18da817cd05eb3272eabec2151599d702 libstrophe-0.8.6.tar.gz"
+sha512sums="5c93a199d223d0995c99688dcd9af1586e17ce825d0df3cdac33498c87af62a41a60b4a727910754f064541c64f9b79d5db899a265a1cc3d9c4380e42b525e5a libstrophe-0.8.6.tar.gz"