aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/lua5.2-sec-prosody
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/lua5.2-sec-prosody
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/lua5.2-sec-prosody')
-rw-r--r--unmaintained/lua5.2-sec-prosody/APKBUILD55
-rw-r--r--unmaintained/lua5.2-sec-prosody/Makefile.patch11
2 files changed, 66 insertions, 0 deletions
diff --git a/unmaintained/lua5.2-sec-prosody/APKBUILD b/unmaintained/lua5.2-sec-prosody/APKBUILD
new file mode 100644
index 0000000000..ac0372f894
--- /dev/null
+++ b/unmaintained/lua5.2-sec-prosody/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Borys Zhukov <borys@zhukov.im>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=lua$_luaver-sec-prosody
+_name=luasec-prosody
+pkgver=0.5.1
+pkgrel=0
+pkgdesc="Temporary fork of lua-sec necessary for prosody to support certificate authentication"
+url="https://prosody.im/doc/depends/luasec/prosody"
+arch="all"
+license="MIT"
+depends="lua$_luaver-socket"
+makedepends="lua$_luaver-dev openssl-dev"
+install=
+subpackages="$pkgname-doc"
+source="
+ https://prosody.im/tmp/luasec-prosody-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/$_name-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make linux \
+ CC="${CC:-gcc}" \
+ LD="${CC:-gcc}" \
+ MYCFLAGS="$CFLAGS" \
+ MYLDFLAGS="$LDFLAGS" \
+ INC_PATH="$(pkg-config lua$_luaver --cflags)" \
+ || return 1
+}
+
+package() {
+ _luasharedir=/usr/share/lua/$_luaver
+ _lualibdir=/usr/lib/lua/$_luaver
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/$_luasharedir "$pkgdir"/$_lualibdir
+ make LUAPATH="$pkgdir"/$_luasharedir \
+ LUACPATH="$pkgdir"/$_lualibdir \
+ install
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ cp -r samples "$pkgdir"/usr/share/doc/$pkgname/
+}
+md5sums="fbe70f5b43419bec16afdfee2b21c34b luasec-prosody-0.5.1.tar.gz"
+sha256sums="2fd34cf9c59a6491937c98ba33921d4fc418b160c0c89545f7bae4f246280ad4 luasec-prosody-0.5.1.tar.gz"
+sha512sums="eadae7f59e957ebc8df074c8e43b181380393e8dd2042bbd098576bf2d7710aa0abb4ccc87eb1b52d28e0473cc52626be6e06eabdec8821deca1cda82ad7cfe7 luasec-prosody-0.5.1.tar.gz"
diff --git a/unmaintained/lua5.2-sec-prosody/Makefile.patch b/unmaintained/lua5.2-sec-prosody/Makefile.patch
new file mode 100644
index 0000000000..958c24a1be
--- /dev/null
+++ b/unmaintained/lua5.2-sec-prosody/Makefile.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.orig
++++ b/src/Makefile
+@@ -22,7 +22,7 @@
+
+ INSTALL ?= install
+ CC ?= cc
+-LD ?= $(MYENV) cc
++LD = $(MYENV) cc
+ CFLAGS += $(MYCFLAGS)
+ LDFLAGS += $(MYLDFLAGS)
+ DESTDIR ?= /