aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/lxpanel
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 07:51:13 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-11 16:16:43 +0000
commit640b988f625ce77cdeb7cc8c58bf3ff1a560b01c (patch)
treed2173cc1fa81b55d1fa2dd6a01f241856aa3a172 /unmaintained/lxpanel
parent9e11a23e5aabf36ed1e2d3e7c235d97b4eb9cb30 (diff)
downloadaports-640b988f625ce77cdeb7cc8c58bf3ff1a560b01c.tar.bz2
aports-640b988f625ce77cdeb7cc8c58bf3ff1a560b01c.tar.xz
unmaintained/lxpanel: move from testing
Diffstat (limited to 'unmaintained/lxpanel')
-rw-r--r--unmaintained/lxpanel/10-devproc-lxpanel-0.6.2.patch21
-rw-r--r--unmaintained/lxpanel/APKBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/unmaintained/lxpanel/10-devproc-lxpanel-0.6.2.patch b/unmaintained/lxpanel/10-devproc-lxpanel-0.6.2.patch
new file mode 100644
index 0000000000..0932a4be25
--- /dev/null
+++ b/unmaintained/lxpanel/10-devproc-lxpanel-0.6.2.patch
@@ -0,0 +1,21 @@
+--- a/plugins/netstat/devproc.c
++++ b/plugins/netstat/devproc.c
+@@ -25,15 +25,15 @@
+ #include <net/if.h>
+ #include <net/if_arp.h>
+ #include <arpa/inet.h>
+-#include <linux/sockios.h>
+-#include <linux/types.h>
+-#include <linux/ethtool.h>
+ #include <iwlib.h>
+ #include "nsconfig.h"
+ #include "netstat.h"
+ #include "statusicon.h"
+ #include "devproc.h"
+ #include "dbg.h"
++#include <linux/sockios.h>
++#include <linux/types.h>
++#include <linux/ethtool.h>
+
+ /* network device list */
+ static void netproc_netdevlist_add(NETDEVLIST_PTR *netdev_list,
diff --git a/unmaintained/lxpanel/APKBUILD b/unmaintained/lxpanel/APKBUILD
new file mode 100644
index 0000000000..3916ed09ce
--- /dev/null
+++ b/unmaintained/lxpanel/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Maintainer:
+
+pkgname=lxpanel
+pkgver=0.9.3
+pkgrel=1
+pkgdesc='Lightweight X11 desktop panel'
+arch='all'
+url='https://lxde.org/'
+license='GPL'
+makedepends='gtk+2.0-dev alsa-lib-dev menu-cache-dev libwnck-dev
+ wireless-tools-dev docbook-xml docbook-xsl intltool libfm-dev
+ linux-headers libxml2-dev keybinder-dev'
+subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
+source="https://downloads.sourceforge.net/sourceforge/lxde/$pkgname-$pkgver.tar.xz
+ 10-devproc-lxpanel-0.6.2.patch"
+
+builddir="$srcdir"/${pkgname}-${pkgver}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-silent-rules
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c6aea97f66ee1d576822fda0bf1aed3849b3c74bab856816b7d23331e48b26005f1ba12eddcc0abbf5a6f08add3cb4a0674ccd13f118cec0b6294edd6f1b2343 lxpanel-0.9.3.tar.xz
+198174624d27198dc229a676d9cee1f56ee4528a5fd8dddf20ed474d3731c90e7f7ba706e3ffb8c8d0b200caece83aa0f3f365726fbf8ad6733996d2c9522914 10-devproc-lxpanel-0.6.2.patch"