aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/nbtscan
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/nbtscan
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/nbtscan')
-rw-r--r--unmaintained/nbtscan/APKBUILD47
-rw-r--r--unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch20
2 files changed, 67 insertions, 0 deletions
diff --git a/unmaintained/nbtscan/APKBUILD b/unmaintained/nbtscan/APKBUILD
new file mode 100644
index 0000000000..61cbb2bddb
--- /dev/null
+++ b/unmaintained/nbtscan/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=nbtscan
+pkgver=1.5.1
+pkgrel=0
+pkgdesc="A NetBIOS name network scanner"
+url="http://www.inetcat.net/software/nbtscan.html"
+arch="all"
+license="GPL2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://www.sourcefiles.org/Networking/Tools/Miscellanenous/nbtscan-1.5.1.tar.gz
+ $pkgname-$pkgver-makefile.patch"
+_builddir="$srcdir"/$pkgname-"$pkgver"a
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="85bb085077c380b82a6ff73e0de0c154 nbtscan-1.5.1.tar.gz
+513430ac89e76bfdb2fd9f8bfce4cca2 nbtscan-1.5.1-makefile.patch"
+sha256sums="f9f95d5555356c8d467a576e69d9d348bf2a821ded9a85f895b5e6d21e2aa7eb nbtscan-1.5.1.tar.gz
+b2787e59b5b21f6f5a3d766438889daea25c3a321406c4bd275493b8cd8742ed nbtscan-1.5.1-makefile.patch"
+sha512sums="2e2ac6a3ce7b188552c4f5f82b1e2bb99049bd0cd6f69361c59066c0b262d9311186aabc0c03c3096b7d2c48276052b1ddf230eba43051e221019c9bf223ae3e nbtscan-1.5.1.tar.gz
+75668565aef5d07d848c55d322c543b9394d372898d239bfb04eb2265bb0262e3b89c5bd35772db6775f4b825e13914dc792b38e09260e26a1a512e39059e1fa nbtscan-1.5.1-makefile.patch"
diff --git a/unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch b/unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch
new file mode 100644
index 0000000000..300f2a6aef
--- /dev/null
+++ b/unmaintained/nbtscan/nbtscan-1.5.1-makefile.patch
@@ -0,0 +1,20 @@
+--- nbtscan-1.5.1a/Makefile.in.orig
++++ nbtscan-1.5.1a/Makefile.in
+@@ -5,6 +5,7 @@
+ OBJECTS=nbtscan.o statusq.o range.o list.o
+ DEFS=@DEFS@
+ TARGET=@TARGET@
++DESTDIR=
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -14,7 +15,8 @@
+ $(CC) $(CFLAGS) -o nbtscan $(OBJECTS) $(LIBS)
+
+ install:
+- $(INSTALL) $(TARGET) $(BINDIR)/$(TARGET)
++ mkdir -p $(DESTDIR)$(BINDIR)
++ $(INSTALL) $(TARGET) $(DESTDIR)$(BINDIR)/$(TARGET)
+
+ nbtscan.o: nbtscan.c statusq.h range.h list.h
+ $(CC) $(CFLAGS) $(DEFS) -c nbtscan.c