aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/p0f/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/p0f/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/p0f/APKBUILD')
-rw-r--r--unmaintained/p0f/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/p0f/APKBUILD b/unmaintained/p0f/APKBUILD
new file mode 100644
index 0000000000..025d51b5e9
--- /dev/null
+++ b/unmaintained/p0f/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=p0f
+pkgver=3.05b
+pkgrel=0
+pkgdesc="Passive traffic fingerprinting tool"
+url="http://lcamtuf.coredump.cx/p0f3/"
+arch="all"
+license="GPL"
+depends=
+depends_dev="bash libpcap-dev"
+makedepends="$depends_dev"
+install=
+subpackages="$pkgname-doc"
+source="http://lcamtuf.coredump.cx/p0f3/releases/$pkgname-$pkgver.tgz"
+
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+ cd tools
+ make p0f-client
+ make p0f-sendsyn
+ make p0f-sendsyn6
+}
+
+package() {
+ cd "$_builddir"
+ install -d -Dm755 ${pkgdir}/usr/sbin
+ install -d -Dm755 ${pkgdir}/etc/p0f
+ install -d -Dm755 ${pkgdir}/usr/share/licenses/${pkgname}
+ install -d -Dm755 ${pkgdir}/usr/share/doc/${pkgname}
+ install -m744 p0f ${pkgdir}/usr/sbin
+ install -m755 p0f.fp ${pkgdir}/etc/p0f
+ install -D -m644 docs/COPYING ${pkgdir}/usr/share/licenses/${pkgname}
+ install -D -m644 docs/README ${pkgdir}/usr/share/doc/${pkgname}
+ install -m744 ${srcdir}/${pkgname}-${pkgver}/tools/p0f-client ${pkgdir}/usr/sbin
+ install -m744 ${srcdir}/${pkgname}-${pkgver}/tools/p0f-sendsyn ${pkgdir}/usr/sbin
+ install -m744 ${srcdir}/${pkgname}-${pkgver}/tools/p0f-sendsyn6 ${pkgdir}/usr/sbin
+}
+
+md5sums="edbc4b135b2646db3227a441268fd2e2 p0f-3.05b.tgz"