aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/perl-pdf-api2
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/perl-pdf-api2
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/perl-pdf-api2')
-rw-r--r--unmaintained/perl-pdf-api2/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/unmaintained/perl-pdf-api2/APKBUILD b/unmaintained/perl-pdf-api2/APKBUILD
new file mode 100644
index 0000000000..0162ba7419
--- /dev/null
+++ b/unmaintained/perl-pdf-api2/APKBUILD
@@ -0,0 +1,43 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=perl-pdf-api2
+_pkgreal=PDF-API2
+pkgver=2.025
+pkgrel=0
+pkgdesc="Facilitates the creation and modification of PDF files"
+url="http://search.cpan.org/dist/PDF-API2/"
+arch="noarch"
+license="open_source"
+cpandepends="perl-font-ttf"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/S/SS/SSIMMS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name uniglyph.txt -o -name perllocal.pod -o -name .packlist \) -delete
+ mv "$pkgdir"/usr/share/perl5/vendor_perl/* "$pkgdir"/usr/lib/perl5/vendor_perl
+ rm -fr "$pkgdir"/usr/share/perl5
+}
+
+md5sums="d8b5e8a8a08986816a0e97d5236de979 PDF-API2-2.025.tar.gz"
+sha256sums="123b49cd459526662d9e0c98c68a52294132051327abe07af1255d599e6d62ea PDF-API2-2.025.tar.gz"
+sha512sums="0dc2e880e77c1beabeed49a6dff0378ebed3eca8f7235a199bd8ffd1b3394af11e0ba2e9f662686407c5c03fde84590c57634ed6e9063c2684578772c2786f5c PDF-API2-2.025.tar.gz"