aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/phpredis
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/phpredis
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/phpredis')
-rw-r--r--unmaintained/phpredis/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/phpredis/APKBUILD b/unmaintained/phpredis/APKBUILD
new file mode 100644
index 0000000000..6c745c3f49
--- /dev/null
+++ b/unmaintained/phpredis/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer:
+pkgname=phpredis
+pkgver=2.2.7
+pkgrel=0
+pkgdesc="The phpredis extension provides an API for communicating with the Redis key-value store"
+url="https://github.com/phpredis/phpredis"
+arch="all"
+license="PHP"
+depends=""
+depends_dev=""
+makedepends="php-dev autoconf"
+install=""
+subpackages=""
+source="https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ phpize
+ ./configure
+}
+
+package() {
+ cd "$_builddir"
+ make || return 1
+ make INSTALL_ROOT=$pkgdir install || return 1
+}
+
+md5sums="f10bada46b6e1a15eac613df4f298f51 2.2.7.tar.gz"
+sha256sums="a5882dd9b21908e123b3d5c5f72d6dc8cbbbb6a29996e568c4d18ed356c0362b 2.2.7.tar.gz"
+sha512sums="eddca71c76fc39f46a316ac204521f352cba30cb2999a7b91fe907bdb0f17e287be025df2f7c3b7115790b1c2a781c162b32c77d29daf30b246bd4d163e5404e 2.2.7.tar.gz"