aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/polygraph
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-01 17:26:53 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-01 17:26:53 +0100
commit3ce3c4fd596debefbad77328a9b62a39eccf753c (patch)
tree8ea8842d946335dbd124e71336a11b928481c544 /unmaintained/polygraph
parent62b8ba5f8fe6d62d56b2d078b4f12f72830ee4af (diff)
downloadaports-3ce3c4fd596debefbad77328a9b62a39eccf753c.tar.bz2
aports-3ce3c4fd596debefbad77328a9b62a39eccf753c.tar.xz
unmaintained/*: purge aports not touched since v3.5.0
We agreed with ncopa on #alpine-devel (2017-12-01 16:20 UTC) to periodically purge aports in unmaintained that haven't been touched in last 1 year (2 releases).
Diffstat (limited to 'unmaintained/polygraph')
-rw-r--r--unmaintained/polygraph/10-fix-ftbfs-gcc-4.7.patch77
-rw-r--r--unmaintained/polygraph/APKBUILD53
2 files changed, 0 insertions, 130 deletions
diff --git a/unmaintained/polygraph/10-fix-ftbfs-gcc-4.7.patch b/unmaintained/polygraph/10-fix-ftbfs-gcc-4.7.patch
deleted file mode 100644
index b066680cdd..0000000000
--- a/unmaintained/polygraph/10-fix-ftbfs-gcc-4.7.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-Description: Fix ftbfs with GCC-4.7.
-Author: Mònica Ramírez Arceda <monica@debian.org>
-Bug-Debian: http://bugs.debian.org/667326
-Last-Update: 2012-05-11
-
---- a/src/xstd/Heap.h
-+++ b/src/xstd/Heap.h
-@@ -23,7 +23,7 @@
- const Item &top() const { return this->theItems[1]; }
- Item &at(int idx) { return this->theItems[idx+1]; }
-
-- void add(Item v) { append(v); floatUp(++theCnt); }
-+ void add(Item v) { this->append(v); floatUp(++theCnt); }
- void skip() { this->theItems[1] = this->theItems[theCnt--]; this->theCount--; sinkDown(1); }
- Item shift() { const Item v = this->theItems[1]; skip(); return v; }
-
---- a/src/xstd/Ring.h
-+++ b/src/xstd/Ring.h
-@@ -22,11 +22,11 @@
- int size() const { return Array<Item>::size(); }
- bool empty() const { return this->theInOff <= this->theOutOff; }
- bool full() const { return count() >= this->theCapacity; }
-- const Item &top(int off = 0) const { return item((this->theOutOff+off) % this->theCapacity); }
-+ const Item &top(int off = 0) const { return this->item((this->theOutOff+off) % this->theCapacity); }
-
-- Item &top(int off = 0) { return item((this->theOutOff+off) % this->theCapacity); }
-- void enqueue(Item i) { Assert(!full()); item(this->theInOff++ % this->theCapacity) = i; check(); }
-- Item dequeue() { return item(this->theOutOff++ % this->theCapacity); }
-+ Item &top(int off = 0) { return this->item((this->theOutOff+off) % this->theCapacity); }
-+ void enqueue(Item i) { Assert(!full()); this->item(this->theInOff++ % this->theCapacity) = i; check(); }
-+ Item dequeue() { return this->item(this->theOutOff++ % this->theCapacity); }
-
- void reset() { this->theInOff = this->theOutOff = 0; }
- inline void resize(int aCap);
---- a/src/runtime/StatPhase.cc
-+++ b/src/runtime/StatPhase.cc
-@@ -413,12 +413,12 @@
- break;
- }
- } else {
-- static CompoundXactInfo &compound = *CompoundXactInfo::Create();
-- compound.exchanges = 1;
-- compound.reqSize = reqSize;
-- compound.repSize = repSize;
-- compound.lifeTime = repTime;
-- compound.record(rec.theIsolated);
-+ static CompoundXactInfo &compound2 = *CompoundXactInfo::Create();
-+ compound2.exchanges = 1;
-+ compound2.reqSize = reqSize;
-+ compound2.repSize = repSize;
-+ compound2.lifeTime = repTime;
-+ compound2.record(rec.theIsolated);
- }
-
- if (x->cookiesSent() > 0)
---- a/src/cache/CacheEntryHash.cc
-+++ b/src/cache/CacheEntryHash.cc
-@@ -14,7 +14,7 @@
-
- CacheEntryHash::CacheEntryHash(int aCapacity): theCount(0) {
- theCapacity = (aCapacity + aCapacity/3 + 7) | 1;
-- theIndex = new (CacheEntry*[theCapacity]);
-+ theIndex = new (CacheEntry*[this->theCapacity]);
- memset(theIndex, 0, sizeof(CacheEntry*)*theCapacity);
- }
-
---- a/src/tools/IntIntHash.cc
-+++ b/src/tools/IntIntHash.cc
-@@ -13,7 +13,7 @@
-
- IntIntHash::IntIntHash(int aCapacity): theHashCap(0) {
- theHashCap = (aCapacity + aCapacity/3 + 7) | 1;
-- theIndex = new (IntIntHashItem*[theHashCap]);
-+ theIndex = new (IntIntHashItem*[this->theHashCap]);
- memset(theIndex, 0, sizeof(IntIntHashItem*)*theHashCap);
- }
-
diff --git a/unmaintained/polygraph/APKBUILD b/unmaintained/polygraph/APKBUILD
deleted file mode 100644
index 7f6737e820..0000000000
--- a/unmaintained/polygraph/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
-pkgname=polygraph
-pkgver=4.3.2
-pkgrel=1
-pkgdesc="Performance testing tool for Web intermediaries"
-url="http://www.web-polygraph.org"
-arch="all"
-license="Apache2"
-depends="zlib-dev"
-depends_dev=
-makedepends="$depends_dev"
-install=
-subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.web-polygraph.org/downloads/srcs/$pkgname-$pkgver-src.tgz
- 10-fix-ftbfs-gcc-4.7.patch
- "
-
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
-
- # remove the 2 lines below (and this) if there is no init.d script
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
-}
-
-md5sums="74d9ad75ed355afbbeefa166954da54f polygraph-4.3.2-src.tgz
-3c7399d3f005c8afb867e9ea3f0d6f4c 10-fix-ftbfs-gcc-4.7.patch"
-sha256sums="b0104448ff3c2f29cebeb5ad5ee6e6f670438d8b78fa095fd54f3b16d99569bb polygraph-4.3.2-src.tgz
-65185b6b695e62efa39cc778fd253afef250b2999eeec8b3e29b41369db3cdb0 10-fix-ftbfs-gcc-4.7.patch"
-sha512sums="a660427f9e21dddb102a172238823091c64983ca6eb938eb5aa9cd1d980e2b2b061614f41162000c838514d164124e08c0fe4517bda1e3f2bf6498831957674b polygraph-4.3.2-src.tgz
-e091fb9cab4cb3053df532df9012cd093a7eb3493aad112ba38eb31d534185bc83c6b9b5eeb424316f9354b04d13a3a92a1af45e6134a60690e5f4a6b3180a27 10-fix-ftbfs-gcc-4.7.patch"