aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-acl
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/py-acl
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/py-acl')
-rw-r--r--unmaintained/py-acl/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/py-acl/APKBUILD b/unmaintained/py-acl/APKBUILD
new file mode 100644
index 0000000000..028dee7dac
--- /dev/null
+++ b/unmaintained/py-acl/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-acl
+_pkgname=acl
+pkgver=0.4
+pkgrel=0
+pkgdesc="A python network access control list parsing library"
+url="https://github.com/jathanism/acl"
+arch="noarch"
+license="ASL 2.0"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="$_pkgname-$pkgver.tar.gz::https://github.com/jathanism/acl/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="3015448d787469e6d9b250d07ca877d1 acl-0.4.tar.gz"
+sha256sums="805a8568c6c1584f35a32b2a212547f479d064bc0fedd5a06531725caf4c65c1 acl-0.4.tar.gz"
+sha512sums="57b0bf0d444084de55b7d2f98b08ee97bb3e740a2fbf469e6dc2b294ac5c70bd67cd506417de791d7c67acca4ea0ed66873a6e84c5a28ad44e590616ae7d5ef5 acl-0.4.tar.gz"