aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-beautifulsoup
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/py-beautifulsoup
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/py-beautifulsoup')
-rw-r--r--unmaintained/py-beautifulsoup/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/unmaintained/py-beautifulsoup/APKBUILD b/unmaintained/py-beautifulsoup/APKBUILD
new file mode 100644
index 0000000000..5cb0d4068d
--- /dev/null
+++ b/unmaintained/py-beautifulsoup/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-beautifulsoup
+_pkgname=BeautifulSoup
+pkgver=3.2.1
+pkgrel=0
+pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
+url="http://www.crummy.com/software/BeautifulSoup/index.html"
+arch="noarch"
+license="BSD"
+depends=""
+depends_dev="python-dev"
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://www.crummy.com/software/BeautifulSoup/download/3.x/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="5ad1a8550a19bfc945baac23eb8293ed BeautifulSoup-3.2.1.tar.gz"