aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-stencil
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 08:50:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 09:04:24 -0300
commit0cb3849713bd6ed28d09ec2f689a8d0db8150974 (patch)
treedf45edd9e3bd8d7b527bde1d7bbb5086bb130bed /unmaintained/py-stencil
parenta782da6afe62a5f20b56d8b38f30f01c95d1f46e (diff)
downloadaports-0cb3849713bd6ed28d09ec2f689a8d0db8150974.tar.bz2
aports-0cb3849713bd6ed28d09ec2f689a8d0db8150974.tar.xz
unmaintained/py-stencil: move from testing
- No longer developed since 2011 - Python2 only
Diffstat (limited to 'unmaintained/py-stencil')
-rw-r--r--unmaintained/py-stencil/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/unmaintained/py-stencil/APKBUILD b/unmaintained/py-stencil/APKBUILD
new file mode 100644
index 0000000000..1f03fc6d18
--- /dev/null
+++ b/unmaintained/py-stencil/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-stencil
+_pkgname=Stencil
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A Python module to creates files and directories from templates"
+url="https://github.com/trilan/stencil"
+arch="noarch"
+license="BSD"
+depends="python2"
+makedepends="python2-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="18d42d8b30141a55074ea8c6dcd0d07bcdd65f3effe7eef2fa525b6580e3cef30a28ee22a61c94432316a898ed2fe6408c12279be9e8c82108ea220bf79b549c Stencil-0.2.1.tar.gz"